Group mssd if the grp list menu is longer than height of display [M635][GUI]

Group missed if the group list menu is longer than the height of the display.

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?: Yes, always
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened: Advanced Settings → Security Settings → Defense+ → HIPS → Protected Objects → Protected Files → Groups → Add several groups, make sure that the group list menue is longer than the height of the display(I added another 20 groups), press OK, back to the Protected Files window, Add → File Groups. Then you may find that several groups are missed in the list, because CIS does not provide a up and down arrow when the group list menue is longer than the height of the display.
  • If not obvious, what U expected to happen: There should be a group of up and down arrow to make all the added groups can be displayed.
  • If a software compatibility problem have U tried the conflict FAQ?: NO conflict.
  • Any software except CIS/OS involved? If so - name, & exact version: NO
  • Any other information, eg your guess at the cause, how U tried to fix it etc: NO.
  • Always attach - Diagnostics file, Watch Activity process list, dump if freeze/crash. (If complex - CIS logs & config, screenshots, video, zipped program - not m’ware): Attached

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration: CIS 6.3.294583.2937, Proactive configuration

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV: AV Stateful, HIPS Enable Safe Mode, BB Paritially limited, Firewall Safe Mode
  • Have U made any other changes to the default config? (egs here.): NO
  • Have U updated (without uninstall) from a CIS 5?: NO
    [li]if so, have U tried a a clean reinstall - if not please do?: NO
    [/li]- Have U imported a config from a previous version of CIS: NO
    [li]if so, have U tried a standard config - if not please do: NO
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used: Windows 7 SP1 32-bit , UAC enable, Administrator, NO V.Machine.
  • Other security/s’box software a) currently installed b) installed since OS: NO

[attachment deleted by admin]

This appears to be a GUI bug. Thus, I will move it to that part of the bug reporting forum and add it to the tracker.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

Not fixed in version 6.3.297838.2953.

Thank you for checking this.

I have updated the tracker.

Not fixed in version 6.3.300670.2970.

Thank you for checking this.

I have updated the tracker.

Can you please check and see if this is fixed with the newest version (7.0.313494.4115)? Please respond to this topic letting us know whether it is fixed or if you are still experiencing the problem.

Thank you.

PM sent.

Mike replays me as following:

Sciter is the GUI framework in which CIS.exe is programmed. So Egemen is saying this is unfixable until Sciter fix it.

I think this issue is not related to CIS but Sciter.

So this post could be closed, thanks.

This has not been closed in the tracker. Therefore, I would prefer to leave it open, at least for now. If there is an issue with the programming language they use perhaps they have plans to improve it eventually. I will let you know if they close it through the tracker.


If you are able please check with the newest version (CIS version and let me know if this is fixed on your computer with that version.

Thank you.

This bug still has not been addressed in the new version. (CIS version

Thank you for checking this. I’ve updated the tracker.

Not fixed in version

Not fixed in Comodo Internet Security

Fixed in Comodo Internet Security 2019 (v12.0.0.6810). Now it has a scrollbar when list reaches the max viewable size.