At, my system has passed every test except one; the IMCP Ping Test. So I have edited in Comodo Firewall
->Network Security Policy
->Global Rules
…the one rule that is there, which is the IMCP Ping rule that says that from any source address to any destination address the ping should be blocked if the message is an echo request. I have changed that to ‘block from any source IP to any destination IP if the message is ANY’.

However, my system is still responding to IMCP pings from

The Firewall Security level is ‘Safe mode’.
The Defense and Security Level is ‘Paranoid Mode’.

How to remedy this hole in the firewall? Why is it happening?

Are you connecting through a router?


If this is the cause, would you explain to me in simple terms why?

grc might ping your router, and not your computer.

Check if your router has itself a firewall, and if so, if you can disable the ping in it.

If not, the test shall always fail.