Google Desktop


Has anybody tried comodo firewall with Google Desktop? I’m having problems.

After the install I logon and get as expect a lot of prompts to allow access, I’ve OK’d all these and ticked to remember the settings. However GD doesn’t won’t fully start, the icon is there on the systray but not fully loaded - appears to be hung, on logoff XP prompts to end the Google Desktop task.

I’ve tried changing the application settings for the all the google exes Desktop, Crawl, Display and Index to allow any activity but they still fail.

The route of the problem seems to be that comodo logs suspicious activity IP - tried setting up rules to allow this, but still fails.

Any ideas?

Please update your CPF to version and make sure you have the latest google desktop.


OK. Will try that this weekend.

:DTried the updated version and google desktop is now happily coexisting.

:(Unfortunately there still seem to be problems. I now don’t get all my task tray icons - for example add/remove hardware and the Nvidia sound applet tray icon.

This probably doesn’t have anything to do with Comodo. This is a known fault with Windows XP - not common - and Microsoft are not definitively sure of the cause. Do a google for the term “missing tray icons” and you should find several possible fixes.

I’m not saying it couldn’t have been Comodo, but my moneys on XP screwing up.

Hope this helps,
Ewen :slight_smile:

Mostly agree with you and have seen it before. However it happens on all reboots with comodo, remove comodo and put zone alarm back on and the problem goes away.

hmmmmm …
There’s two possibilities - 1)the Comodo install is actually causing this or 2) the Comodo install is creating the environment that allows the XP bug to trigger.

Have you tried installing CPF and then applying the XP system tray fixes?

I would recommend you try this, as the firewall is really brilliant.

Here’s a couple of links for possible fixes:

More and more of these possible fixes seem to revolve around UPnP - Universal Plug and Play. Is UPnP enabled? If so, do you run hardware that will only run with a UPnP driver? If not, the Gibson Research site ( has a free downloadable tool that lets you turn on or off the UPnP service. Their recommendation is to turn it off unless absolutely required and I tend to agree with them. You could downloadthis tool, turn off UPnP, reboot and see if the issue has gone away, or changed in nature. If nothing else, it may give us a pointer of where to look next. I realise a gradual process of elimination is not necessarily the quickest way to find a solution, but it worked for my in-laws! :smiley: LOL

If the problem still exists after applying the fixes, please send an email to The tech guys there are among the best I’ve ever come across and Comodo as a company are particularly responsive.

Hope this helps,
ewen :slight_smile:

P.S. If this does fix the issue, can you please post here so everyone else can benefit. Thanks

Thanks for your continued help. Lots of info in those links so will be working my way through them.

One of the first suggestions I read was to set ‘Hide icons for networked UPnP devices’ I did that and my icons returned, however Google Desktop Search now doesn’t startup correctly again (same symptons I started with).


First I installed Comodo Anti-virus (Build Version:, VD Version: Then I installed Google Desktop. After Google Desktop install, both seemed to co-exist peacefully.

The problem arose when I attempted to install Pidgin chat. The installation stalled and no blue pop-up appeared on the right side of the screen. The set up would not advance and I could not get the blue pop up in order to confirm the installation was acceptable.

Upon reboot I shut down Google Desktop’s side bar (that’s the mode it was running in at the time of the difficulty) and Pidgin’s install was flawless.

I think the pop-ups are somehow inhibited by Google’s Sidebar.

Product Information
Build Version:
DataBase Version:
AllowDB Version:
Program Updates Version:

License Information
License Status: Activated
Product Installation Date: 09-Oct-2008
Product Activation Date: 09-Oct-2008

Program Files Information

System Information
Operating System: Windows XP
Operating System Version: 05.01.2600
Service Pack: Service Pack 3
Internet Explorer Version: 7.0.5730.13

Hardware Information
Central Processing Unit (CPU): AMD Athlon™ XP 2000+
Total Memory: 511MB


This is the wrong thread because it’s about Comodo Firewall 2, not Comodo AntiVirus 2. Also, CAVS 2 is obsolete - you might want to check out Comodo Internet Security that includes CAVS 3.

As this thread is quite old and really irrelevant to your issue, I shall end it. If you need assistance please open a new thread or post in the correct board.