Global rules are not saved for blocking ports

win xp sp3
Avast 4.8 home
CFP 3.025.378

configuration : D+ not installed, Firewall with Leak protection installed.

Problem faced : not true stealth,

Solution applied: i tried to block the incoming and outgoing connection by creating a global rule of type
Block tcp/udp from source port any to Dest port 0-2

this rule has no effect,

So i tried another rule , i modified the In rul as :
Allow TCP/UDP In from sorce port any to dest port 2-65535 ----------------------------(1)

I can not save this rule,
after clicking apply and closing all windows when this windows is open again rule is changed to allow port 0-65535

I have even tried doing this from Admin account also.

I am attaching my output of CfP V3 config file

Kindly suggest some methode to save this port setting.
Diagonstic does not find any error

Regards to all


[attachment deleted by admin]

Hello to all, :■■■■

The problem is solved,

How I dont know? From admin account, I deleted all global rules and recreated themand added

Block TCP/UDP souce Ip any Dest. Ip any Src port any Dest port 2-65535"

It worked, On checking it was found full stealth :BNC

there is some problem I think Comodo leak protection is not stable It sometime does not allow modifications of rules in registry ( It is Not to be relied much).

something must be done by comodo coder to move settings from registry to disk as It present a serious danger to system stability uptime as these settings could quickly grow to unmanageble size unless the person is using default settings like outgoing only, Trusted application etc.

Regards to all