Given up

on Comodo Email Certificates. No matter what I do, it doesn’t work. Tried using the CSE software and all I got was " -2 Unrecognised argument". Tried requesting manually from the website and got no email at all! I now have two email addresses which Comodo says certs are issued for… and no certs!


Could you tell me which OS and which browser you are using?


Hi, Dalriadan.

Error: “-2 Unrecognised argument” is reproducing sometimes if you try to click on the button inside Certificate Collection E-mail. We found and fixed this issue. Fix will be uploaded to the server tomorrow.
But it will fix all new certificate requests.
For your case you need:

  1. Navigate to:!SecureEmailCertificate_Collec2
    2 )Fill your e-mail address field
  2. Copy your “Collection Code” from your e-mail and fill proper field on the page.
  3. Accept certificate installation.

NOTE: Please, make sure that you’re installing certificate on the same PC that you’ve requested it.

I hope this post will help in resolving your issue. Feel free to ask any questions on Comodo SecureEmail (CSE).

Please, check your SPAM folder for the e-mail from Comodo Web-Site. Or contact support and ask to resend your Collection e-mail.

Regards, Eugene.


Issue with error “-2 Unrecognised Argument” has been fixed for all new certificate orders.
For already ordered certificates - see instructions in the post above.

Regards, Eugene.