Ghost Recon Advanced Warfighter 2 and COMODO

I’m new to this forum so have patient with me.So here is my question/plead for help.
When ever i try to play this game on some random servers i can not get in,i can see list of servers,number of people playing it in some servers, but i can’t join the game on servers.When i uninstall COMODO firewall i can connect to any server.

This is my COMODO configuration for GRAW 2:
Allow all Requests
Protocol:TCP or UDP
Direction:In and Out
Source Address:Any
Destination Address:Any
Source Port:Any
Destination Port:Any

I don’t have any of this problems with games like TFT2,Dawn of War - Soulstorm, etc…
Can anybody tell me how to configure my COMODO firewall so i can play this game online?

Just use Vett’s Gamer Mode ! ;D Set the defense + to train mode and launch the game. The firewall then learn all the things it needs. Play for a couple of minutes and exit. Set the firewall to your desired position and launch the game again. It should work flawlessly :slight_smile:

Use this trick on other games that cause you trouble playing or connecting online :wink:

You don’t need specific rules for any game. I play them all and everyone works. Just follow my thread. I also play GRAW.

I’m grateful for your replay but this didn’t help me.All i can see when i’m trying to connect to a server is “connecting to server”,and i can not connect to a server.Now when i don’t have COMODO it connects itself very fast,but with COMODO i’m only receiving quoted message.

Remove the GRAW entries from the firewall and D+ and click apply. Reboot leaving D+ and the firewall in training mode and start GRAW. I actually manually add all my games to the firewall and D+ as trusted. Works like a charm. You can edit GRAW in the firewall and D+ and make them trusted and try that. GRAW also uses Gamespy servers last time I checked so be sure Gamespy is also aloud to connect.

Ok i have try all of this and still can’t connect to servers.I have looked in Readme and saw this.

"You may experience difficulty connecting to Gamespy if a firewall or anti-virus blocks the following ports:

Local Ports
UDP 13139
UDP 16250

Remote Ports
UDP 16250
TCP 80
TCP 443
TCP 6667
UDP 13139
UDP 27900
UDP 27901
TCP 28910
TCP 29900
TCP 29901
UDP 29910
TCP 29920"

How can i enable this ports?I have a feeling that COMODO is blocking GameSpy (i can log in and browse through the servers) and i don’t know how to unblock it.I’m on Vista 64 bit Home Premium,windows firewall is disabled.

You dont need to. Make Gamespy a trusted program in the firewall and D+ like I did. Are you logged into Gamespy?

I actually dont game much on my pc anymore since I got my 360. Live is so much better.

The problem is there is no Gamespy in installation folder.Here is a screenshot of installation folder.

Have you always been able to play GRAW online? Or is it just since you installed Comodo? When you installed GRAW it gave you the option to install Gamespy. Get out your cd and install Gamespy or just download it. You need Gamespy installed if you want to play games that require Gamespy servers.

This crazy problem is only occurring with Comodo.That is way i’m thinking that Comodo is blocking something, and i don’t know what it is.GRAW 2 dvd disk does not have Gamespy,but i have it and still can’t connect to servers.I can log in to Gamespy (i can see all the servers,number of people playing it online,i can use refresh button etc…) from the game,but still can not connect to servers.

Do you have an entry in Comodo under the firewall and D+ for Gamespy? If not add it. If its installed then you have it. Just find the directory. Do your logs say anything? Look for Gamespy in your GRAW folder.

I have Gamespy installed and I have an entry in D+ and the Firewall for Gamespy. If Comodo is blocking it then there should be something in your logs about it.

Ok here is a screenshot of Network Security Policy:

Firewall Events:

Compuer Security Policy:

Am i missing something?

Make it trusted. Also System and explorer should be outgoing only.