Gene6 FTP Server not working with Comodo

I was using ZoneAlarm Pro 7 and uninstalled it and started using Comodo. Everything was good up until I was testing the FTP server which I couldn’t get working. I tried making it a Trusted Application in the Firewall and in Defense+. I searched the forum but couldn’t solve the problem.

I’m using Gene6 FTP Server v3.10.0.2 Professional, Comodo Firewall Pro, Windows XP SP3. The FTP is on port 21. I tried setting the FTP Server in both active and passive mode (ports 50000 to 50100) but the FTP client would time out and not even log into the server. I couldn’t connect using another computer in my network (which is configured as a trusted network).

Can someone post a detailed solution to getting the FTP server to work?

Just a small question, does it work when you disable the firewall ?

How are your global rules defined ? you need at least to allow

TCP In from any(or some zone/ip) to any source port any dst port 21.

After you made this “hole” in your global rules the firewall should ask you if you try to connect to the ftp server application, you can than allow this and later modify the rules to fit your needs.

If that works you have to do the same for the port range and then it should work.

It did not work when I disabled the firewall. I was reading another post and someone else had that problem too.

The global rules are the default.

I just realized that my Windows Firewall was enabled. After I disabled it, then the FTP server worked (at least in the trusted network) while Comodo was running. I guess Comodo doesn’t configure the Windows Security Center after installing it to turn off Windows Firewall.

Yes the problem is solved. I was able to remove the program as Trusted and let Comodo prompt for the Allow access and doing so worked. (For some reason when I try to reply it says that I posted within 1 second ago and it doesn’t let me post).

So problem solved ?

Good afternoon.

I have the same versions of Comodo Firewall and Gene6 FTP Server. And still can’t connect to the server from my work. I should tell you that it’s possible if I connect from the same computer.

I have turned windows firewall off(as for Domain, as for Public, as for Private). By the way, do you have your windows firewall off when using Comodo? (I use Vista Ultimate x64)

I have configured Gene6 FTP to accept connections not on 21 port, but on 10021.
I have in global rules:

Allow TCP In/Out from ANY IP to ANY IP to FTP Ports (21, 10021, 20, 50000, 50100). - I’ve defined “My ports group”.

Having only this rule - I couldn’t connect to the server and while trying no logs or popups were heard from Comodo :frowning:

I have created in application rules:

Allow G6FTPServer.exe TCP In from ANY IP to ANY IP to FTP Ports.

Still nothing. What should I do? (I hate that I can’t see in logs if my connection was blocked… I’m just blind without it!)

P.S.: In addition - my work computer is well configured to allow outgoing FTP connections. I have CPF here also, so I’ve configured to allow OUT on port 10021 and in on port 20. So the problem is on home CPF :frowning:

Hmmm… Just restarted the computer and all the logs successfully started to write. And I can connect to my FTP Server now.

There is a bug somewhere. I can’t find where, but it’s definitely there in Firewall. Before restart no new logs were added(last time - 10 hours ago), even if a rule fired which SHOULD be logged. And in addition no new rules worked(like above with FTP server connections). I restarted and everything became normal.

Anyone faced the same?