Geekbuddy won't run

2 days ago I managed to get in touch with Geekbuddy and was helped by Charles. My computer kept locking up and unfortunately the last time I tried to get back on Geekbuddy won’t open. My laptop is an Acer Aspire V3-571. I am only able to use safe mode and can’t use the normal software. My pc locks up and now after Charles was trying to help I get a blank black screen with no icons and no mouse just a locked up screen. Is there someway I can get back onto Geekbuddy using safe mode? I’ve done every scan for everything and deleted new additional software. Can someone help please?

Hi Honey0708,
A bit of a long shot, but do you have a system restore point prior to the issues?

Thank you for getting back to me.

I did go back to the last good configuration at the time but still could only use safe mode. In desperation I tried some other software and found a trojan virus hiding in my registry. The software also found some other junk in the registry which has now been sent into cyberspace! I managed to get in contact with GeekBuddy techs via their website and they gave me a link to a fresh download. Yahoo! All working again thank goodness now back to study! :slight_smile: I have now got my Comodo software cruising along and protecting me. I would like to know how that got past my defences!


Hi Honey0708,
No defense is 100%.
Glad to hear that you got it sorted in the end. :-TU