Geekbuddy bug freezing my keyboard and touchpad

Good morning, I am writing to inform about a bug in Geekbuddy that froze my laptop’s keyboard and touchpad. USB ones would work. It was observed in 4 computers, all of them Gateway MT6723. In all of them the problem was fixed by either desintalling geekbuddy or disabling it from Windows startup (all of them run windows 7 enterprise edition).
Hope it help you to improve your product, or if you have a similar problem


This is an isolated issue, since GeekBuddy operated on laptops for a very long time without such problems. It may be caused by certain drivers or software products that interfere with GeekBuddy’s functionality. In order to determine the cause and to see what ca be done to fix this issue, please provide us with more details about your laptop: configuration, operating system, programs installed, drivers installed, version of GeekBuddy. It would be helpful if you provided a screenshot or list of your installed programs/applications. If you are willing to do this, please send me a private message with the screenshot attached. Also a short description of the scenario that leads to the problem you described might be useful.

Thank you for reporting this issue.

Hi, Just to confirm you are not alone, I had exactly the same problem on a Lenovo IdeaPad Flex 14 touchscreen running windows 8.1 64bit, your Solution fixed this Serious Problem… DISABLED Geekbuddy and now everything works OK!! Many thanks for posting this solution, just wish I found it earlier, spent a full day trying to sort this out!

COMODO please look at this Serious Issue and fix it! I am afraid GeekBuddy not so friendly after all! or is this a 'Create the problem and offer $ a solution…?

Please provide the information Adrian Bosoiu requested above. Without the requested information they cannot identify what is causing the issue.

I am also experiencing this problem. I ran CIS Complete 2012 with no problem. I then bought a new years license in November of 2013 and downloaded CIS Complete 2013 and used it up till this month without a problem with the internal keyboard and touch pad.
I was looking to upgrade to Windows 8 and saw that 2013 was apparently not compatible with 8. I got in touch with Geekbuddy and was given a link to a Beta version. I still have Windows 7. I uninstalled CIS Complete 2013 and installed the Beta. After rebooting my keyboard and touch pad worked to put in my password and for less than a minute while windows opened and started to load drivers and start up programs. Then they stopped responding. My wireless mouse worked and I could plug in a USB keyboard but the internals wouldn’t work.
I had just reinstalled the operating system and had made a back up with very few things loaded. Comodo was not loaded. I wiped the partition and reinstalled the back up and everything worked. I contacted Geekbuddy and got a link to a non beta version of Comodo. I installed it. After rebooting my keyboard and touch pad stopped working. I uninstalled Geekbuddy and they worked again.
I have a Dell L701X laptop running an I5 processor. I am running Windows 7 Ultimate with Service pack 1

I solved the same issue deleting in “Safe Mode” all of the Comodo’s lastest update with the exception of cavshell.dll.
I love Comodo, not very trill with Geekbuddy…
By the way, how do get rid of cavshell.dll?

This is still an issue, Comodo-Staff
Froze my Touchpad and the Keyboard, USB worked. Now had to deinstall GeekBuddy and it works again.

Hello again,
I still have my Dell L701X. I loaded Windows 8.1. I saw that the version of Comodo Internet Security Complete I had downloaded was not compatible with it. I got in touch with customer support and was given a link to a version of was supposed to be compatible with Windows 8.1. I started with a fresh install of Windows 8.1. The only thing I installed other than that was Microsoft Office 2007 Pro and Revo Uninstaller Pro. I made a image using Clonezilla. I then installed Comodo Internet Security Complete Version 6.3.306037.2978.

When I rebooted the internal keyboard and touch pad wouldn’t work. I could use an external mouse. I tried to uninstall Comodo using Revo Uninstaller Pro. The computer went to a BSOD. I restored the laptop using the Clonezilla image. It worked fine. I installed Comodo again and the touch pad and keyboard stopped working again. I uninstalled Geekbuddy and the touch pad and keyboard worked again.

Has a fix or patch been produced for Geekbuddy?

I would be interested in hearing a response from Comodo about this issue. As I work for a computer store that sells and installs a lot of Comodo licences, I’ve had this same issue countless times. Everything from XP to Windows 8 laptops and of all brands. It’s not an isolated issue. Lately it seems I have this problem with about 1 out of 3 installs. Its to the point that I don’t feel comfortable recommending this to customers with laptops due to the fact that GeekBuddy is one of selling points and yet I have to disable it just to get the computer to function again.

Well I am a computer consultant and past Compaq systems engineer. I experienced this same issue and was finally able to remove geek buddy, and I now have my PC back. The laptop this crashed was a Dell N7110 series running Windows 7. After calling in the geek buddy folks told me this is a known bug. It appears that this has been on going for far too long and it does not appear to be ISOLATED as Comodo staff has indicated above.
As a software reseller and installer for a small group of very active users I cannot say my initial impressions are positive.
I lost a full day getting this off my PC.
Requesting a refund. Shame I cannot get my time back.
I would not recommend this product to anyone.
Jeff Houtkooper