gcswf32.dll and Google Chrome - Comodo freezes

Google Chrome 10.0.648.127 and the gcswf32.dll interacts as shown in the attached screenshot.
The problem is Comodo Defence+ alerts for these events and if I click Allow it blocks Chrome window and also the Comodo GUI.

I tried to access some websites when Comodo triggered this alert: www.gsp.ro and https://chrome.google.com/webstore/detail/gffjhibehnempbkeheiccaincokdjbfe. These are only two examples I rememmber now.

I’m using Comodo Firewall, version 5.3.181415.1237, with Sandbox disabled, with both Defence+ and Firewall on Safe Mode.
My OS is: Windows 7 Home Premium x86 and I am also running Avira AntiVir Personal 10.

This takes many minutes, and it happens sometimes to other apps I want to run. Can you fix or indicate a solution?

[attachment deleted by admin]

We would very much appreciate it if you would edit your first post to create an issue report in line with the bug forum guidelines and format here. You can copy and paste the format from this topic.

To understand the reasons why we ask you to follow these guidelines please see below.

Bugs/issues can be impossible or very time consuming to fix if developers don’t have enough information to reproduce them. Since CIS is free, development time is limited. So if you want your issue fixed, please use the format below to describe it.

To avoid clutter, issues not described in the format below your post will not be moved to the ‘moderator verified’ issues topic. This means that the developers may not look at it.

Best wishes and many thanks in anticipation


I have updated my previous post. Is this ok now ?

Comodo still blocks that .dll
The dll belongs to Adobe Flash player, and it’s version 10.2r included in Chrome version I specified.
What can I do ?

Example of bug report in the correct format below.

Thank you


Unlimited access alerts generated for program defined as an installer/updater

The bug/issue

  1. What you did: Applied the Installer/updater policy to myprog.exe, rebooted, then ran myprog.exe
  2. What actually happened or you actually saw: Unlimited access alert
  3. What you expected to happen or see: No alert
  4. How you tried to fix it & what happened: Ticked ‘don’t ask again’ on the alert, did not work
  5. If it’s an application compatibility problem have you tried the application fixes here?:
  6. Details & exact version of any application (except CIS) involved with download link: myprog.exe v. 5.1.005 (Beta), www.xyzwprog.com/download
  7. Whether you can make the problem happen again, and if so precise steps to make it happen: Yes. a) Check Myprog is installer/updater in Computer Security Policy ~ D+ rules b) run Myprog from Start menu ~ All programs ~ MyProg c) Get Unlimited access alert d) tick don’t ask again and press allow e) close program f) Re-start Myprog from same location g) get Unlimited Access alert
  8. Any other information (eg your guess regarding the cause, with reasons): D+ malfunctioning under load - cpu usage was high at the time.

Files appended

  1. Screenshots illustrating the bug: Appended
  2. Screenshots of related CIS event logs or the Defense+ Active Processes List: Appended
  3. A CIS config. report or file: Appended
  4. Crash or freeze dump file: Not applicable

Your set-up

  1. CIS version, AV database version & configuration used: 5.0.1000.1135, 6770, Proactive config
  2. a) Have you updated (without uninstall) from CIS 3 or 4: Yes
    b) if so, have you tried reinstalling (if not please do)?: Yes
  3. a) Have you imported a config from a previous version of CIS: Yes
    b) if so, have U tried a preset config (if not please do)?: Yes
  4. Ave you made any other major changes to the default config (eg ticked ‘block all unknown requests’, other egs here.): No
  5. Defense+, Sandbox, Firewall & AV security level: D+=Safe, Sandbox=Enabled, Firewall=Safe, AV=Stateful
  6. OS version, service pack, number of bits, UAC setting, & account type: Windows XP, SP3, 32 bit, None in XP, Admin account.
  7. Other security and utility software installed: CAS
  8. Virtual machine used: Vmware player

Unfortunately we do need this issue to be reported in the full right format, and with all the information we have asked for, if we are to forward it to verified issues.

For the moment I am going to move it to the Orphaned/Resolved child board. If you do edit your post to create a complete issue report in standard format, and PM an active mod, we will of course consider moving it to verified reports.

The devs only look at the Orphaned/Resolved board if they have time, so please do edit the post and PM an active mod if you want it fixed.