Functionality lost after Version 3.9.95478.509?

After upgrading past Comodo Firewall Version 3.9.95478.509, it seems like a very major functionality was lost: If I decided to block a particular application from accessing the Internet, if it was listed on some Comodo-managed “safe list”, the application would still have full access to the Internet even though I wanted it blocked. Comodo seems to override my settings.

Is this the way that Comodo operates now? Or, is there a configuration option that I missed in later Comodo versions? For now, I’m using Comodo Version 3.9.95478.509 until I find another option …

Please let me know if I’m missing something here …



Hmmm… No, you aren’t missing anything. If you block a file, it should be blocked.

Can you give more specifics? Any file or files in particular that we may have on our systems to test this issue?

I am running WinXP SP2 Pro.

When I upgraded from Comodo 3.9.95478.509 to the next release, everything I had blocked now had free access to the Internet.

Before I upgraded from Internet Explorer 6 to Internet Explorer 7, I had Windows Explorer blocked from all access to the internet. (This was due to a hidden executable / trojan that had run on my computer once that used used Windows Explorer to FTP some unknown file to someplace in Eastern Europe). Since I never use Windows Explorer to get on the Internet, it was fine for me to block all internet access - and it also provided a useful tool to check if Comodo was working properly after an update. (Note: The Windows Explorer test doesn’t work after I upgraded to IE7, since now Windows Explorer will automatically start up IE7 when a URL is entered into the path field in Windows Explorer).

I also had Adobe_Updater blocked, and it wasn’t blocked after upgrading.

It has been a few months since I “downgraded” Comodo back to 3.9.95478.509 (for me it was an upgrade). I’m not sure, but I think that the “Settings >> Update >> Automatically perform an online lookup” option is no longer available after that update (or maybe it isn’t working).

I tried to reproduce the behaviour you described. I set the Firewall to Safe Mode. I deleted FF cache and closed FF. Then I changed the rule for Firefox (which is on the safe list) to blocked. When I started FF it could not connect anymore.

I think something has gone wrong with your configuration. Please do a clean install of the yesterday released v 3.12: .

OK, cool! Will I be able to import my 3.9.x configuration into 3.12?

That’s not advisable because of some internal changed made to the saving of the policies to improve system response during heavy alerts of CIS.

My configuration seems to be working OK after the clean install. Maybe I had a problem before because I upgraded?