Full Scan Being Aborted

I have run into a very unusual issue when conducting a full system scan.
For a while now I have found that performing a full system scan will complete to a certain point and then end and simply state “Status: Scan Aborted”

In an attempt to find what is going wrong I decided to perform manual scans on individual folders starting at root c: and narrowing down where the issue lies and then doing scans from within that folder on the sub-folders, and so on.

I successfully found the folder that was causing the scan to abort but doing individual scans on the sub-folders inside does not produce any errors and does not show any malware being found.

However, if I scan multiple folders then it produces the “Status: Scan Aborted” error, but only on 3 of the folders. Scanning these folders individually does not produce any error.
I can access these folders perfectly fine and even copied them to a different directory in order to test the scans in a new location, but the same problem still occurs.

The folders in question are to do with dotnet (C:\Program Files\dotnet\sdk\NuGetFallbackFolder\netstandard.library) and only happens with the sub-folders named “2.0.0”, 2.0.1" and “2.0.3”. To repeat I can scan these folders successfully without issue but I cannot select any combination of these folders together and scan them without the scan aborting.

I am using:
Windows 10 version 1903 build 18362.175
CIS v12.0.0.6818

I set Comodo to save logs to Event Viewer and the entry it produces appears the same every time. An example of the warning log is as follows (with “*****” omitting certain details for privacy):

- 2 3 0 0x80000000000000 247392 COMODO Internet Security CEF ****** - Jul 07 2019 23:02:11 0000 ****** CEF:0|comodo|cis.premium|12.0.0.6818|ACBA8518-B7EB-4E04-A44B-27B6D34F6D5E|Antivirus scan|6|act=scan reason=av_user cat=av cs1Label=second_cat cs1=av cs2Label=total cs2=476 cs3Label=found cs3=0 cs4Label=complete_code cs4=-2147467260 suser=****** start=1562540531000 end=1562540531000 dvchost=****** dvc=********* deviceExternalId=**********

How big are this folders combined? I ask because maybe you can provide a compressed archive of them for Comodo to test.

I did some further testing and managed to narrow it down to a collection of files/folders.

It is a collection of 233 files, in 6 folders, totaling ~42mb. They scan perfectly fine until they are all selected and scanned together which results in the scan terminating with the above mentioned “Scan Aborted” problem.

I have not been able to narrow it down further as I have not had time, but I would be happy to send these files to you in order to find and fix this issue. How would be the best way to send these to you?

Upload it to a file sharing service and provide a download share link.

I have zipped and compressed the 3 folders that cause this issue:
https://www.mediafire.com/file/mvmkqocfbf2r1d4/ComodoTestFiles.7z/file

Inside are 3 folders “2.0.0”, “2.0.1”, “2.0.3”.
When scanned individually the scan of the folder and contained files completes perfectly fine.
Selecting any combination of these folders (e.g. “2.0.0” + “2.0.3”) and doing a scan results in the scan being aborted partway through.

I’d be very interested to know what the cause of this is.

I tried with 12.0.0.6870 and it does finish eventually, however it does hang on some specific files depending on if decompress and scan compressed files scan option is enabled or disabled within the scan profile. I haven’t seen the scan abort unless I click cancel.

That’s very odd. I’m doing a test on those folders I uploaded again right now.
If it aborts then I’ll look at the scan settings and tweak a few things to see if it makes any difference. It’s entirely possible that it’s some setting. Not sure why it would do this if I have more than of the mentioned folders selected to scan at the same time, but it works fine if done individually.

Can anything be suggested from the error log that I posted above?

Hi MatrixShield,

I have reported to our developers about the issue, if possible could you please share us some screenshots.

Ok, I did some further testing and managed to get the scan to complete.

I went into settings/antivirus/scans and edited the “Manual Scan” option. I toggled off various options and ran numerous scans to see what worked. Every scan completes successfully except for when I have “decompress and scan compressed files” selected.

The settings I have enabled in Manual Scan that causes the scan to abort on these folders is as follows:

  • Decompress and scan compressed files
  • Use cloud when scanning
  • Show scan result window (can’t be changed)
  • Update virus database before running
  • Detect potentially unwanted applications
    All other settings in this section are disabled.

I have uploaded a few screenshots for you. Hope this is of some help.