Free TrustConnect not working, first noticed jan 2011...

Free TC is not working for me - I have it on an iPod, a Windows PC and a Mac, and it has worked on all 3 in the past. Now it seems that the server is not responding in some way. Here is the log from the Windows PC:

Tue Jan 04 18:17:55 2011 OpenVPN 2.1_rc4 Win32-MinGW [SSL] [LZO2] built on Apr 25 2007
Tue Jan 04 18:17:55 2011 LZO compression initialized
Tue Jan 04 18:17:55 2011 Attempting to establish TCP connection with
Tue Jan 04 18:17:55 2011 TCP connection established with
Tue Jan 04 18:17:55 2011 TCPv4_CLIENT link local: [undef]
Tue Jan 04 18:17:55 2011 TCPv4_CLIENT link remote:
Tue Jan 04 18:18:34 2011 Connection reset, restarting [-1]
Tue Jan 04 18:18:34 2011 SIGTERM[soft,connection-reset] received, process exiting

On the Mac (using TunnelBlick instead of TrustConnect), I get this error:

2011-01-04 18:22:08 WARNING: Make sure you understand the semantics of --tls-remote before using it (see the man page).
2011-01-04 18:22:08 NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
2011-01-04 18:22:08 LZO compression initialized
2011-01-04 18:22:08 *Tunnelblick: Obtained VPN username and password from the Keychain
2011-01-04 18:22:09 Attempting to establish TCP connection with [nonblock] 2011-01-04 18:22:10 TCP connection established with
2011-01-04 18:22:10 TCPv4_CLIENT link local: [undef]
2011-01-04 18:22:10 TCPv4_CLIENT link remote:
2011-01-04 18:23:11 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
2011-01-04 18:23:11 TLS Error: TLS handshake failed
2011-01-04 18:23:11 Fatal TLS error (check_tls_errors_co), restarting
2011-01-04 18:23:11 SIGTERM[soft,tls-error] received, process exiting
2011-01-04 18:23:11 *Tunnelblick: Flushed the DNS cache

Finally, on th eiPod, I simply get a pop-up message:

The PPTP-VPN server did nor respond.

My credentials are all correct, I get the same response from several different wi-fi networks, so what is wrong?

Temporarily issue with a free service for iPod client was fixed. Please try to connect again.

It’s kind of ridiculous - now my two laptops are able to connect, but my iPod is still on-and-off. Sometimes it works, sometimes not.

I am sure it will be sorted out, if there are further problems, after all it’s a FREE service they are offering so are allowed a minor set back now and again, they never take long to get it sorted asap anyway.


Access via PPTP protocol for free service has been checked and there were no problems detected. Doesn’t your Wi-Fi connection break for some reason?

My 2 cents …
The same problem ( disconnection after 40 seconds ).
I had this problem with a Virtual Machine running IE8 …
I solved it using an older VM with IE6 … even if in this case Default Gateway is not assigned automatically ( I put it manually … )
My connection sometimes experiences some up and down …