free comodo firewall does not allow me to connect to the internet

Hi every one, I have the Free comodo firewall and when enabled it will not connect to my wireless internet. It had no problems before but I had to reinstall it and ever since then it will not work properly. Any help asap would be great thanks.

I just got the same problem.

I have CIS installed on my laptop (which I’m using at the moment). I was browsing, then turned off my wireless and closed Avast! and Comodo because I was playing Oblivion and wanted as many resources as possible available. I then went for dinner, and returned a few hours later, turned on my wireless, started up Comodo and Avast! to continue browsing but only received this error message when trying to navigate anywhere:

It’s not the same error message you get when you’re not connected at all, so I thought something funny was going on. I tried IE7 (gah) but that simply came up with the: “Internet explorer cannot display this page” message.

I tried the diagnostic thing and as firefox had hinted, there was SOME connectivity but it wasn’t useful at all.

So I went to Comodo, tried shifting the firewall down from “Safe” mode, to training. I figured it only learns in training mode, but apparently not. It still came up with the same errors. If I set the firewall to “Disabled” it works fine, hence I’m typing here.

I’m feeling a bit vulnerable here relying on the Windows firewall. Any suggestions? Possibly I changed some settings by accident when closing Comodo to play the game? I’m not sure. I tried flicking through some settings, and as expected it didn’t do anything.

Help? ???

Edit: This may be related, seems it’s not limited to XP? Might be the same problem. Possibly something went wrong with an update somewhere along the line?

I’ll try uninstalling and reinstalling, see if that helps, although thats not a preferable option because it means I’ll have to set everything up again :frowning:

yupp your in the same boat as me, but on my dads it is a direct internet connection and it does not work for him. But if I plug mine in at home it works. So any one who knows a solution to this problem help please thanks.

This issue might occur if your default gateway IP address in the My Blocked Zones in Comodo Firewall. Hence I suggest you to check if if your default gateway IP address is in the My Blocked Zones in Comodo Firewall.

Click My Blocked Network Zones in Firewall Tasks > Common Tasks to open My Blocked Zones interface and check if there are any listed.

If there are no IP address listed under the blocked zones, then check if your web browser is set to allow all requests in the Application rules tab in the Network Security policy of Advanced Firewall Tasks.

Firefox set to “treat as web browser”, no specific network zones were blocked so something else must have gone wrong.

Works with a reinstall though. I ran scans with Spybot, Avast! and Comodo just to make sure everything was clean, then uninstalled comodo. Restarted, reinstalled and it looks like it’s all working okay. Just running updates now.

It’s a bit of an annoyance, but overall not too much hassle to get a firewall up and running again. It’s worth the effort :slight_smile:

Thanks :slight_smile:

Since you had freshly installed CIS you may have missed an alert while eating.

@Haiyun211. Does your internet connection at home work when using a wire when you are at home?

About your dad’s situation. Try running Diagnostics (can be found under Miscellaneous). What are the settings for System under Application Rules (Firewall → Advanced → Network Security Policy)?

Yes when plugging it in with the Ethernet cable it works at home and I have not changed any of the settings just using the defaults since they worked last time I have reinstalled it about 3 times and nothing has helped.

Are you using the latest drivers for your wireless?

Just found this topic:;msg187131 . May be it helps.

Are you willing to try one more uninstall and then manually clean out all possible leftovers of CIS? Here is the drill:

Start with exporting your configuration to a folder that is not part of the Comodo folder under Program Files. This way you can restore your configuration after the reinstall.

Uninstall CIS and reboot. Then run Comodo System Cleaner to get rid off registry keys.

Then delete the Comodo folders under Program Files, Program Files\Common Files, %username%\appdata\local, %username%\appdata\roaming\ and %username%\appdata\local\virtual store .

To be even more thorough open Device Manager and set it to show hidden devices under menu option View. Then see if there are Comodo driver(s) left in non Plug and Play drivers. If so select the driver → click right → uninstall and reboot.

Then delete:
C:\boot.ini.comodofirewall (this file may not exist).
WARNING: Do not mistakenly remove the original “boot.ini”.

Now you should be good to go and give the install a try.

Thanks EricJH. The link to the other issue helped out. The problem was that my svchost was set as a web browser instead of out going only. For anyone else with this problem here is how I fixed it. Go to comodo firewall → click on advanced → click on Network security Policy → look for one that says C:/Windows/system32/svchost.exe and make sure that it says outgoing only if it says web browser then highlight it click edit and then change it to outgoing only. Hope this helps anyone with the same problem. And thanks again to every one who helped me solve this problem.

I think I have the same exact problem. I uninstalled Comodo and reinstalled it and rebooted. When my comp loaded back up, it said Comodo was already uninstalled. So now I have no Comodo program, and can’t get online. But in my Windows Task Manager under processes, I have 7 svchost.exe processes, some saying “System”, some saying “Local Service” and 2 saying “Network Service.”

I have no idea where to go from here because I still had a Comodo folder/option in my Start Menu but it’s just an empty program (it’s an icon with a whitebox and a blue top) and when I click on “Comodo Internet Security” it starts searching for cfp.exe.

I’ve been trying to fix it for the last 4 hours, and have already searched for malware/spyware with 3 different programs awhile ago, when I thought that could be the problem. I need HELP!! ???

*I’m on another comp btw.

I had this problem when I installed the new beta version of Opera 10.

I went into a few configurations, and I added Opera, and rebooted, but it did not permit Opera to connect to the Internet.

I’m running the RC version of Windows 7. Could that have something to do with this glitch?

Well now I’m pretty sure it has nothing to do with the NETWORK SERVICE and LOCAL SERVICE part of svchost.exe, but i’m pretty sure svchost.exe is trying to become my browser or something as stated previously. I have no idea what to do.

Delete the D+ and firewall rules for Opera and try again. That should do the trick

Dire. It looks like something went not quite right with uninstalling. Can you try the suggestions I gave in the above:;msg271139#msg271139 ? That may help to get rid off possible left overs of CIS.

Keep us posted.