FIX -Comodo Freezes PC, don't have permission to access

For those of you who have posted this kind of thing before, thank you for letting everyone know what did or did not work for you. This is a brief but complete overview of the problem, the symptoms, and several solutions.
This occurred under WinXP.

I installed a program and afterwards I ran it.
Comodo popped up and asked what to do, & I choose “isolated application” +Always Remember.
At this point everything locked up.

Every file I tried to open, & all desktop items, & every program I tried to run now gave me the message:
“Windows cannot access the specified device, file, or path. You may not have the appropriate permissions to access the item.”
I tried to right-click on the Comodo Icon in my taskbar but nothing happened.
I did the Ctrl+Alt+Del and attempted to use Task Manager to end cmdagent.exe but I got “Access Denied”.

  • Other people have reported these symptoms:
    -can open the shortcut/folder “My Computer”, but can’t do anything in there.
    -can’t run a single program in the start menu.
    -can’t access control panels or start any new programs.
    -can’t get into Control Panel’s “Add/Remove Programs” to uninstall Comodo.
    -can’t go into registry (regedit) or administrative services (services.msc)
    -can’t turn off the machine. (Hard Shutdown =hold-down the physical power button for about 3 to 10 seconds)

So I clicked the Start button & clicked Turn Off Computer, & after several minutes the PC finally shutdown.

NOTE: Shutdown keyboard shortcut: Ctrl+Alt+Del, select “log off” then choose “options” and shut down.
“it takes a long long while to shut down…”

Now I rebooted and ran an Antivirus, Antispyware, & Rootkit scanner and found nothing. :slight_smile:
Hoping WindowsXP had a one-off memory problem, I restarted the PC and found there was no icons near the time, no icons in the quick start

taskbar either, and I still couldn’t run any programs “don’t have permission”.
Now I am the only user, and run with admin permission, & at work… I am the Admin. >:(
(Needless to say, I wasn’t too happy with this turn of events, or the stupid message Windows kept giving me.)

Comodo & Other Websites:
I wen’t online using another PC.
I googled “Comodo freezes xp” and kept getting less then helpful information, even on this website. (Sorry :o)

Last resort suggestions are the most common first suggestions:
But I suspect many people give up before even trying… >:(
Suggestions of: “reinstall Windoze”, “last known good configurations”, “System Restore”, ghosting the OS back, “just unistal Comodo”,

“simply open up Comodo and go to the D+ tab. …and see what is blocked.”

Now this may come as a shock to everyone in the world but…
I don’t want to uninstall Comodo, use System Restore, or Format my HDD & Reinstall Windozes!!!
I just want to restart my PC and have it work like none of this -Frustration- happened!
(Besides many people have Windoze come with the computer, & do not have a disk.)

So I needed to find a fast and viable working solution.


Turn on the PC, boot into “Safe Mode” by tapping or holding down F8. (Google it if you don’t understand)
NOTE: Safemode options are 1.“Safe Mode”, 2.“Safe Mode w/Networking”, 3.“Safe Mode w/Command Prompt”.
So Next I see a login screen with my usual login picture & Username, plus one called ADMINISTRATOR.
I click on the Admin, after a few minutes I get some stupid message about running in Safe Mode, I clicked Yes or OK, or whatever it said.

After a moment XP finally finishes starting up into safemode and now I can see the desktop.
I think at this point I did Ctrl+Alt+Delete and made sure cfp.exe wasn’t running in the taskmanager, & it wasn’t.
I find the Comodo program icon and I double-click on it.
A moment later Comodo is there and responding! :slight_smile:
I click on: Defense+, > Advanced, > Computer Security Policy
Now I see a box with many programs listed, I look for Explorer.exe
I found it and it’s listed as “Isolated Application”, I click it once then click “Edit”.
I see a spot that says “Access Rights” I click it, I change all these rights to Ask except the following:
I changed these rights to “Allow”: Windows Messages, DNS Client Service, Computer Monitor, DiskA

I clicked Apply and looked for other programs that are listed as “Isolated Application”.
The last program at the bottom of the list was the one I just installed before this hassle, its an “Isolated Application”. I changed all

its “Access Rights” to Ask.
Clicked Apply, I closed Comodo, clicked Start, > Turn Off, > Reboot

And a few minutes later I am posting this information on this forum with the PC that had the problem.

I strongly recommend that if you can boot into safemode and can start Comodo;
Then go to Defence+, > Common Tasks, > View Defence+ Events
Now look in the lower right for the “More…” button.
It is here that I could see the events that got blocked. It showed Explorer.exe had been blocked a couple dozen times just after I had

done that software install. I suggest looking at this first because somepeople have reported this trouble with IExplorer.exe, and other

basic level Windows system programs.

BUT… What if this isn’t the solution for you!

  • If in SafeMode you still don’t have permissions, several people reported that they selected a
    different safe mode option and then it worked.

  • If you are still able to open gui window, try to run diagnostics and make C:\windows\explorer.exe as trusted
    app (computer security policy).

  • Boot from a live cd and rename cmdguard.sys (C:\windows\system32\drivers\cmdguard.sys)
    Reboot & if successful you’ll be able to fix rules/remove/reinstall CF when you log in to your system.

  • ??? hard shutdown the pc + F8 to run in safe mode + uninstall comodo firewall.

  • ??? Select Run As… Administrator, and uninstall Comodo.

  • If you feel brave you can try editting the registry in safemode and look for explorer, or whatever programs are locking it up, make sure cfp.exe is not running though.
    Look for
    Find anything Comodo or CFP and then (backup registry key) and Remove.

Or you can try this longer way round.
HKLM\System\Software\Comodo\Firewall Pro\Configurations\0\HIPS\Policy######
HKLM\System\Software\Comodo\Firewall Pro\Configurations\0\HIPS\Policy\Rules\0######
Look through the ###'s till you find the "programs that have Blocked, and change Flags=0 and blank out the TreatAs=

Then there is also this info here in the forums too:

Don’t waste your time with:
Dial-A-Fix “went to tools and told it to fix permissions, but nothing has changed.”
“Try to view or modify the executable or re-take ownership” because the files permissions are not changed.

Don’t bother Emailing me or Posting questions here, this is a brief overview of the current Comodo w/WinXP.
This solution could very well change with the next version of Comodo.
And don’t ask me if any of this will work with Vista because I won’t use Vista ever again, but good luck to ya with it.

Please note this post is not Feedback or Comments or Announcements or News
This is post for the C3 Help Forum where people look for help…

This post is intended to give a simple solution to a BIG problem that Comodo seems to have.
A friendly suggestion is to have it sticky in the C3 Help Forum where the help others received help & where people go looking for it.

Hey Akimbo.

CIS 3.5 is the newest version of CFP 3…

Does this apply to CIS?


I’d like to say thank you Josh “3xist” for posting a link back to this post, under the C3 Help.

“Does this apply to CIS?”
Isn’t “Comodo Internet Security” really just the Comodo firewall bundled with Comodo Anti Virus???
The main solution I’ve used will work for WinXP users using Comodo 3.0 Firewall.
The system that the problem occurred and fix was tested on was: Windows XP SP2 32bit with Comodo Firewall 3.0

But it can all be easily tested by using a WinXP VM appliance, install CIS and “Living Cookbook 2008”.
Run LivingCB for the first time and label it an “Isolated Application” to see if the same “no permission/access rights” thingy occurs again, if so then try my fix and see what happens.
Actually I’m confident that it’ll work for all Comodo’s Windows XP users.

But if it doesn’t work then no harm then because it’s all VMWare/Fusion/whatever VM software.
(Tech Note for newer PC users: VM means Virtual Machine, & Josh will certainly understand)

PS. Josh it appears that I’d turned off the automatic updates at some-point so I was using Version
This was just the Firewall that was installed, I never install safesurf.

Hey Akimbo.

Comodo Internet Security 3.5 is the latest 3.5 update for CFP 3.0, Where you can install the Firewall or AV stand a lone. As you can see, We (As moderators) have archived the Comodo Firewall Board & Comodo AV Board here. So users now post here for the new 3.5 versions for both products, or CIS as a total suite. :slight_smile: So I was wondering whether the solution is for v3.0 or 3.5.

FYI… I made a FAQ here on how/what to choose out of the 3 options when installing “COMODO Firewall” in CIS installation.


Hey Akimbo

Thanks for your detailed post about how comodo CAN freeze your PC! (:HUG) God bless! :BNC

Mine was frozen and thanks to your post, everything is running well now! :BNC

I feel the guys behind comodo should put up a RED FLAG about some actions which a user might unwittingly trigger and that could lead to such freezing!

Let me assure you that even now comodo seems like a nice app but is intimidating and what is definitely needed is some guide lke “Ten steps AFTER you install COMODO to make sure everything is working fine!”

For example, right now I cannot surf the internet unless I have ‘Block Fragmented IP Datargrams’ unchecked!

I do not know a way to surf the net AFTER checking this box!

It wold be awesome if the guys behind COMODO look into this!

Thanks again Akimbo for your post! Are you by any chance from Japan because your id reminded me of Akira Kurosawa and one of his films Yojimbo! (:CLP) :■■■■


Me Paparazzi