First time quick scan crashes on each boot [M359] [v6]

[ol]- Summary

  • Can U reproduce the problem & if so how reliably?: yes. very reliably.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    a. Every time I boot my machine CIS tries to run quick scan
    b. Quick scan runs automatically but it always gets stuck in the point where status says “Windows Live ID Sign-in Helper”. Once I tried to just keep the machine running over night (ran the quick scan one 15h) to complete the scan but it never completes.
    c. I try to stop the scan and press “Stop” in the scaning window, nothing happens.
    d. The Comodo task manager indicates that “Virus Scan – Quick scan” status is “Terminating”, elapsed time keeps running.
    e. current solution I just leave the scanning running on background not being able to stop it or complete it.
  • If not obvious, what U expected to happen: I find this very strange problem because I don’t use Windows live services
  • If a software compatibility problem have U tried the conflict FAQ?: No
  • Any software except CIS/OS involved? If so - name, & exact version: don’t know
  • Any other information, eg your guess at the cause, how U tried to fix it etc: I figured out “windows live id sign-in helper” is associated to file “C:\Program Files\Common Files\Microsoft Shared\Windows Live\WindowsLiveLogin.dll” and its some kind of feature to connect windows login info and Microsoft live login info.
  • Always attach - Diagnostics file, Watch Activity process list, dump if freeze/crash. (If complex - CIS logs & config, screenshots, video, zipped program - not m’ware)

[ol]- Exact CIS version & configuration: CIS 6.0.264710.2708

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV: All, HIPS=safe, BBlocker=Partially limited, Firewall=Safe, AV=cloud is on
  • Have U made any other changes to the default config? (egs here.): No
  • Have U updated (without uninstall) from a CIS 5?: No
    [li]if so, have U tried a a clean reinstall - if not please do?: I have done clean install twice and the problem still persists.
    [/li]- Have U imported a config from a previous version of CIS: No
    [li]if so, have U tried a standard config - if not please do: I have done no config changes
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used: Windows 7, SP1, 64bit, UAC=on, admin, VM not used
  • Other security/s’box software a) currently installed b) installed since OS: a=None b= I had norton internet security triall preinstalled when i bought this laptop 2 months ago.

[attachment deleted by admin]

Thanks for your excellent issue report which is much appreciated. Just a couple of things to make it possible/easier to fix the problem.

  1. Could you please replace the prompts in the issue report as it is very difficult for the devs to read without them

  2. Could you please try to track down what file the scan is actually hanging on using this guidance: here.

Unfortunately the scanner runs ahead of the display, so the file it stops on is unlikely to be the one responsible for the hang.

Best wishes


  1. Sorry for the inconvenience. Now it should be more readable.

  2. I added some details I figured out about this (windows live id sign-in helper) but the link to the guide is not working



Sorry and thanks

Here you go:;msg655013#msg655013

Ok I tried to track down the exact file the scan hangs by folowing the quide. So I ran the scan overnight but there are no items to show in the handles tab(see pic) I also didnt get any kind of crash dialog. Well then tried to create dump file but insted of the dump file being crated i got and error dialog box stating "Error (cavwp.exe) : {Operation failed} The requested operation did not succeed ". I translated the message from the dialog box becouse the original message was in finnish(see pic)

Diagnostics find no errors but i attached the report anyway.

Also took a screenshot of the killswitch process list

Hope this helps.

[attachment deleted by admin]

Sorry need an addition to the instructions. Having checked myself I note there are two cavwp.exe processes running when you do a scan. It’s the one consuming all the cpu cycles you want, both for the dump, and for the handles. Will fix the instructions.

Would you mind re-trying. Almost impossible to fix without this info.

Best wishes


Yes i can give it another go. I want to provide all the best knowledge and information i possibly can.

Problem is that in my processes i can find only one cavwp.exe and i indicates no cpu usage. If there is supposed to be two could this be the problem to begin with. Just wandering becouse the scan doesnt run more than maybe several seconds before getting stuck. It seems to scan only few files before it hangs.

Ah could be it’s crashing then, let me think

If crashing should be a dump somewhere in \users\all users\Comodo.…some subdirectory

Yes that seems to be the problem. cavwp.exe crashes immediately after its being started for scanning. I was able to get trough full system scan by quickly opening the properties of both cavwp.exe’s after i started scannig. This however did not work with the quick scan. It still hangs to the same point as allways.

I managed to do the full scan by immediately after reboot stopping the quick scan before the second cavwp crashes. Becouse its crassing also seems to make it impossible to stop the scanning process. Buy this way i was able to stop it and start full system scan instead. This completed successfully even tho i realized the cavwp still crashed soon after the scan was started. Now that the system scan was successful i wonder if the program is going to start quick scan right after booting the system. At least id does not require this issue to be “Fixed” on the home page.

The dump files are located C:\ProgramData\COMODO\CisDumps
They are also included in diagnostics report. a .zip file attached im my earlyer post

That is fine then, will forward now

Sorry missed the dumps


Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again


No problem. Im happy to help to make my favorite internet security program even better.

I will continue checking out the forum every now and then so that i can be further assistance if needed.


Your help and positive spirit is much appreciated. :slight_smile:


Can you please check and see if this is fixed with the newest version? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

PM sent.

The problem has been solved. Big thanks to Comodo team for fixing the issue and also the support regarding the problem.


Thank you for checking this.

I will move this to Resolved.