First 5.8 install seems buggy

XP SP3 PC, uninstalled 5.5, installed 5.8.211697.2124

:-TU The DB update is now “only” 84MB
:-TD It took 3 attempts before I got it
This could be just congestion due to the number of installs.

After first full scan, cleared the GeekBuddy “ad” (it said 4 items detected) - but no visible results box.
Tried “Restore” from minimized tray tab - no dice (greyed out)
Tried “Cascade” but only main GUI appeared - no trace of results box.
Summary says 4 items but alas, nothing shows up in the list, nothing quarantined, nothing in D+ events, no apparent way of identifying any of the items allegedly detected.

Anyone else having the same issues? Do I have to install GeekBuddy to undo what Comodo has done?

[attachment deleted by admin]

I had a blank D+ log as well.

Do you have any dialog boxes visible or tabs visible with no text showing?

I have a problem with these latter symptoms under XP SP3, also fails to display scan results sometimes.

Some older (pre .dll) programs crash too during scan.

Possibly unique to my machine.

Best wishes