firewall won't run


installed comodo and everything looks fine… but after restart the icon says ‘initializing’ for a while and then eventually 3 alerts popup saying ‘application monitor isn’t working - try reinstall’… none of the buttons to turn on the various components work…

so reinstalled, same thing.

read somewhere her to try using and earlier version so i found and downloaded 2.3 and installed that…

all went well until i restarted then i got the same thing.

restarted again and this time got offered to update so i thought ‘what the hell’ and updated… installed , restarted again the same thing… icon says alls ok but everything is off (except at the moment the network monitor is working) and can’t be turned on…

anyone got any advice?



***edit - also should mention that no other software was installed… comodo was literally the first thing i installed :slight_smile:

I have the same problem and posted about it a few messages down - I hope you (we) find a solution.


BTW, if you move the slider bar to block all connections does it work? When I block all connections I still have an outgoing connection.


i don’t have any internet connection at all when the firewall is like this… if i shut it down i can connect…

i’ll check your thread too to see if any advice comes in there :slight_smile:

Hallo everyone,

When I booted up the computer yesterday I had the same problem as you guys - the firewall was “switched off” and impossible to turn on manually, and with no internet connection. The message from the firewall was that I should reinstall to try to solve the problem. I reinstalled but it made no difference.

I then used the Windows restore program to restore the parameters of about a week ago and everything went back to normal.

I have used the Comodo firewall for about 18 months now and this is the first problem I have ever had with it. I cannot find think of any reason for this curious behavior and would be interested to hear any comments from the forum experts.

It seems strange that I’m not the only one to have such a problem and at the same time too!

shame theres no response to this… sounds like its not an isolated instance…

oh well, i’m going to have to give up on comodo and go back to using Ashampoo firewall… at least that works…

I’m having the same problem! Say’s try and “Re Install May Fix This Problem” But even after that it will not work. Went into registry removed all traces of CPF and no luck. Had to go back to Zone Alarm. Comodo needs to correct this problem. If you uninstall thats it! You can never use CPF again! (:AGY)

Not so, there is a thread on the Comodo firewall section…
Under Help or ASQ I believe (was reading it this morning) which gives a link to a Comodo download file that clears out all Comodo entries to the registry, etc. and allows you to reinstall.
You may need to trawl through the threads to find it unless anyone else can remember where the link is.


Found two links for you…
(post from little mac about half way down the page)
( you need to read most of this thread, several ways of doing it)

Hope that helps.


All that did not work! Again went through the registry and deleted all traces and it still will not load up. Comodo needs to fix this problem! Sheex Zone Alarm is easier to fix! To bad when a company leaves this much garbage in after an install! (:AGY)


Please see my post here:;msg78123#msg78123



this thread has kind of deviated from the problem… its not really a problem of uninstalling, though obviously some have tried doing that to fix the problem…

the error occurs after a restart and then the firewall fails to start properly… as mentioned in my original post going back to an earlier version seemed to work but then it too had the same problem after a restart (or 2 , i don’t remember)…

anyway, i’ve gone back to using ashampoo firewall which is a shame because i thought comodo looked very interesting… but if it won’t work then its not much use to me…

edit : as an update i’ve just restarted one of my other computers which i installed comodo on… the network froze, computer hung and eventually the 3 dialogs telling me comodo has died came up… i’ve not had this much trouble with a firewall since i gave up using Zonalarm 4 all those years ago… unreliable security software is not a good thing…

Sorry the thread got sidetracked, dogstar10 ~

My guess as to your problem is that there was a conflict on the original install, or perhaps since then. When you installed, did you have any active security software running - AV, antispy, HIPS, registry protection, etc? If so, due to the nature of the software, these need to be completely disabled/deactivated/turned off prior to installing the FW.

Other possibilities include AV (if you’re using KAV or AVS, there are known conflicts), OS incompatibility, and some 3rd-party system utilities.

Given the history of this firewall, the stability and number of successful installations, I really don’t think it’s a problem specific to CFP; I think there’s some other conflict or issue that has arisen that is to “blame.” This is not at all uncommon any time you deal with Windows, computers, and software/hardware configurations. If you really want to give CFP a shot, we can work through the process with you and hopefully get it resolved. However, I understand if you don’t feel that the extra effort is worth the end result.

At any rate, we’re here to help however we can.


many thanks for your reply Little Mac…

what makes this problem all the more frustrating is that comodo was literally the first and only piece of software installed on a clean install of XP… honestly, nothing else was installed… restarted after install and got the “3 popups of death”…

i installed a custom install of XP with all hotfixes up to may streamlined… no other software apart from firefox and thunderbird were installed as part of the process…

so maybe its peculiar to this particualr build of xp?

I honestly wish I knew; that certainly is an odd problem. In general, there are no conflicts between XP, Firefox, Thunderbird, and CFP. Only other question I can think is regarding your version of XP… is it 32- or 64-bit?


32bit, though i have a 64 bit processor… that shouldn’t cause any conflict i think?

anyway, the 2nd computer i installed on was a 32 bit AMD using the same version of windows… comodo worked fine for a week until yesterday when it died…

Shouldn’t be an issue; it’s only the version of the OS we’re concerned about, as 64bit OS is not supported by CFP v2.4.

Have you filed a ticket with Comodo Support? If not, it may be helpful for you to do so. You’ll need to register on the Support system in order to file a ticket; your forum registration does not cross over.

When you do this, please provide them a link to this topic (copy from here, paste it there), and make sure you note that a forum Moderator has requested that you file the ticket with them. Please keep us abreast of their response.

Off the top of my head there are only a couple conflicts I’m aware of that cause this - having an unsupported 64bit OS, or Kaspersky AV (or the free AOL version, AVS). I think there were perhaps some similar issues in the past with various system-level utilities, but I’m pretty sure all those were resolved (if I even remember the incidents correctly).

Something must have occurred to cause this, if it was working fine then all of a sudden quit. Did you have any software or hardware/firmware updates? Any drivers, especially? Virus infection? There must have been some change…


I just had the same symptoms here. Except a reboot fixed it. But I shouldn’t have to keep rebooting to get my firewall running again.
There should definitely not be any reason that you cannot turn the various monitors back on again, even after restarting the program. It has done it twice to me in a week.
If they don’t come up with a fix VERY soon then people will start switching to other solutions. Sounds very much like the developers are spending too much time on the next version instead of getting this one right.