firewall won't boot, cfp.exe1 doesn't work

Hello, I updated the firewall the other day. It worked fine this morning until I installed the latest windows security updates (Win Xp SP2) and rebooted the PC.
After reboot I was waiting for Comodo firewall to load before browsing the net. After several minutes it did not load so I began manually through the start menu.

The Comodo firewall icon had changed to the windows unknown file type icon and when I click it says that it doesn’t know how to open cfp.exe1

I haven’t been able to find help for this problem anywhere. I would really appreciate any solutions. No firewall makes me feel wrong.

Uninstall/re-install fixed the problem. There is now no cfp.exe1 at all. And my firewall is all back to normal.

I would like to know however, why would a cfp.exe1 be created and why would the shortcut in the start menu suddenly decide to point there instead of the proper cfp.exe (which I had tried to load manually in windows explorer prior to reinstall, but with no success).

I love this firewall, but I hate absurd happenings like these.