Firewall Update Failure. Help, Please!


I’m a COMODO Firewall Pro User and I use Windows Vista Home Premium SP1. I tried to update my firewall, using the updater, but it did not work. It gave me the following message:

“Error 112: Unable to copy file: cfpsbmit.exe. Please Try Again.”

I am currently using COMODO Firewall Pro Product Version

Can anyone help me please?


Your version may be too old to update. Try uninstalling your version completely and downloading and installing the latest version. Be sure your version is completely gone first. I use Revo Uninstaller in advanced mode.

Have you tried closing CPF3 and then right click on link for CPF3 and choose Run as Adminstrator before you try to update.

I uninstalled it and installed the latest version of COMODO Firewall Pro. It works fine for now but in the future, I don’t know if the updates will be successful. I hope the updates will work. Thanks.


I usually don’t update via the internal updater. I can export my settings uninstall. Then install the latest version and import my settings. Takes about 5 minutes.

I had a similar problem when i tried to update it from a non-admin user. I don’t remember how exactly I fixed it. I tried to use the CPF’s repair utility and it reverted everything to the old version, but I still could not update even from admin account - getting the same error. I had to stop the CPF, manually remove the .exe file causing the problem, replace it with the backup version (it was somewhere in the same directory or in a subdir). After that the updater worked fine (from admin).