Firewall Turned Off

On a number of occasions over the last few months I have found the Firewall monitors turned off, mostly when the computer comes out of standby or hibernation mode. They cannot be turned back on and I have to re-install. Usually I also find Spyware Terminator’s real -time protection is also turned off when this happens.

I have scanned with a wide array of anti-virus/spyware/rootkit etc apps, but no positives.

Any suggestions as to what could be going on? Thanks.


That is very strange, could you please give us some more information? What operating system are you using? What firewall did you use in the past? What other security products are you using?


XPSP2 auto-updated, Previously Norton Internet Security, replaced with Comodo FW, AVG Anti-Virus, Spyware Terminator, SpywareBlaster, Spybot, Ad-Aware, A-Squared, Trend-Micro Rootkit Buster, Sophos Anti-Rootkit. Regular updates and scans. Browse mainly with Firefox, script-blocking on.

There’s a blue and red button on this page encouraging people to join this forum.

What’s the point?


This could be an issue caused by the Norton Internet Security program, I suggest you use Symantec NRT to be sure that all of the Norton components are uninstalled.


So they can get help if they are having any issues with their Comodo software…

Thanks, but the computer was formatted, and then Comodo FW etc installed. Can’t be any traces of Norton remaining.

If it isn’t a glitch in Comodo, which I doubt, it has to be a spyware program. Are there no known programs in the Comodo knowledge base that could be causing this problem?

If only it was that simple. During CFP installation, try to disable other software or do it in safe mode because there have been unusual conflicts reported here before.

You can also file a ticket and link them to this thread.

What happens is that I install the FW and it works fine for weeks on end, but then suddenly all monitors are turned off and can’t be turned back on. As pointed out Spyware Terminator is usually also turned off.

If there are no quick, certain answers here I think I’ll opt for the comprehensive spyware detection procedure at


But your first post is:

Is there another instance that disables the shields? I know it’s a driver conflict of some sort. Two places to look:

  1. Run > Start > type services.msc to see if the Comodo Application Agent is on and Auto mode.
  2. Run > Start > type devmgmt.msc > View menu > Enable Show hidden devices > Comodo Application Engine and Comodo Network Engine drivers should not have a red x or yellow exclamation to indicate they’re disabled or have problems.

“But your first post is:”

I re-install CFP, run it without problems for a while, then one day, when bringing the computer out of standby mode (it is left on during the day, being put into standby when not in use) the monitors are all locked in the off position. As far as I can remember, it has always happened coming out of standby.

I thought I read more threads on this, but only managed to find one in the Help board that’s somewhat related:

That’s interesting, my search here didn’t turn up that thread. Its a relief if that’s the problem, rather have a glitch in the standby mode than malware in control of traffic.

If that is the problem, I’ll just live with it, it doesn’t happen that often and re-installing is less than a couple of minutes.


What you can do is file a ticket to reach the official help team. Maybe they have better answers might find a fix for it. Or maybe v3 doesn’t have this problem. We’ll see :slight_smile:

I have a similar problem. CFP worked fine on a new computer for two weeks. Then all of a sudden, CFP boots with all monitors turned off. All window controls for turning the monitors on or adding and deleting items are disabled. The monitors cannot be turned back on. Also the activity through the system is not logged. It always shows zero activity. CFP just quit working. I have tried uninstalling and reinstalling but the monitors remain off and cannot be changed.

I looked at the services screen and the Comodo Application Agent is configured as Automatic but was not started. I started the service and it made no difference; the monitors are locked in the off mode.

I looked at the device manager and the Comodo devices do not have any flags.

I am running Windows XP Pro, SP2

Welcome to the forum. No software additions/changes during that time? If cmd agent doesn’t load automatically then something is preventing it from loading properly. You should also file a ticket as right now it’s beyond me.

I did some more checking since my earliest post. I looked at services.msc after rebooting and the Comodo Application Agent is flagged as Automatic but the service was not started. I started the service and then checked CFP; the monitors were still locked.

I then closed CFP and restarted the application from the Start Menu and the monitors were all working fine. It appears that the Comodo Application Agent service must be started before the CFP program is loaded.

I hope this helps.

That’s not only logical, but a fact. The Agent is the driver itself and it has to load before the GUI does because that’s what keeps your pc blocking all incoming connections upon boot time.

After watching it more closely, the GUI loads first and can be seen in the tray as an icon. At this point none of the monitors are on. If I manually start the Agent then the GUI becomes active and all monitors are on. The network is also working fully once the Agent service is started.

I always have to start the Agent manually. So I closed the GUI and modified the Agent to restart the service if the service fails. This seems to work but it takes place after the GUI is loaded. Once it starts you can see the GUI change immediately.

I do not know why the Agent does not start first, or, if it does why it fails.