Firewall settings not working - pleas help!

Hi there,

I am having some problems with the Firewall. I’ve set it to “Custom Policy” security level. However, it’s NOT asking me to allow connection for apps trying to phone home or connect to the internet. It automaticallly allows the connection WITHOUT asking me!

What has happened?


:o ??? 88)

This is interesting, you’re the third or forth person to see this effect. Would you mind laying out step by step exactly what you have done by way of configuration and applications tested to observe the Custom Policy mode’s incorrect behaviour. Also, which installer did you use?


Hi there

Many thanks for your reply.

I resinstalled my whole system, and downloaded the free version installer from here:

I then went into the firewall config and changed it to “Custom Policy”. I am installing and running apps that I know Comodo should ask about, but it allows them access without my permission.

If I go into “trusted files”, I can see it’s added a whole bunch of them that it did not ask me about.

I even tried importing my old config, but that did not change anything.

Let me know if you need any more details.

What has happened here?

Will you please check in Firewall Behavior Settings if you haven’t the option “create rule for safe applications” enabled.

Hi there,

“create rule for safe applications” is definitely UNCHECKED.

Many thanks!

Can you give me an example of an application that you believe CIS should ask about, please.

Hi there,

It should ask about, for example:


Etc, etc, etc. I got notifications for ALL of these in my previous installation.


Hey kavakava, could you please look under Firewall->Network Security Policy and see if a rule has been created for “All Applications” Allow all outgoing requests.

Also what configuration are you guys using and what are your Firewall Behaviour Settings->Alert settings set to? I seem to remember something from ages ago that the slider had to be on at least High. Also can you check that all the Enable alerts for boxes are ticked.

Im also trying to reproduce this but dont seem able to!


I have made a fresh install of FW (5.5.195786.1383) for another topic and I can confirm that there is a problem with FW custom policy. It allows clearly everything without a single alert even if Def+ is set in parano mode. This problem doesn’t occur with my usuall installation which was made through update.

Cheers Boris, could you check in Network Security Policy to see if the All Applications rule is there. I f not that can be eliminated as the cause.



I just set the alert level on very high and nothing changes. The only alert given by FW is for IE and quite a strange one :
action : ask
protocol : TCP
source IP :
source port : 1086
destination IP : (loopback zone)
destination port : 12080

After allowing this request, IE connects to google without another popup

No definitively the “all application” is not there. Only applic. rules : Comodo, windows system application and windows updater.

Hi there

“All Applications” Allow all outgoing requests does NOT seem to have been created.

My settings are EXACTLY the same as with my previous installation.

@LvR - Where is the “old” installer you used, as a workaround?


Thanks Boris and kavakaka :-TU going to try doing a clean install from the link in this post and see what happens. Have you just been moving to Custom while staying in Internet Security as your configuration?

Just wan`t to know so i do the exact same routine.


p.s. At least we know it`s not creating an all applications rule (which i think happened in an early 5 Beta)

Hi - Yes, I did a clean install, on a brand new system from the link I posted earlier, free version. Once installed and restarted, I change the Firewall to Custom.

Let us know how you get on!

Just not seeing this at the moment. Fresh install, change the firewall to custom and reboot. Launch any application and get an alert, as I would expect…

Really no idea right now ???


In the test installation I have done, the installer seemed to have been corrupted. cmdagent is running but Comodo drivers have not been installed! The diagnostic tool freeze the computer.

Ok guys, heres what i did. Uninstalled with Revo, re-booted twice so the Control set was sorted. Installed CIS premium from the link, let it do its initial AV update then noticed the “Fix It” sign asking for a re-boot.
Let the AV update, re-booted then set the Firewall to Custom policy.
Tried to update Malwarebytes and no alert! Looked at Network Security Policy and a rule for All Applications (Allow all outgoing requests) had been created (top of pic 3).
Removed this rule, tried again and got the desired alert.

So why is this All Applications rule being created and does it only happen in the Internet Security configuration?
More investigation to follow, either way it`s not good :-TD


p.s. Didn`t install the Geekbuddy part.

p.p.s Windows 7 Pro 32Bit - no other security software running.

[attachment deleted by admin]

Boris and Kavakaa. Can you tell us what OS are you on and if it is a 32 or 64 bits version?