Firewall interferes with ActiveSync?

So I was excited to hear that CIS 4.0 came out, and I downloaded it on Friday, after using 3.0 for quite some time. What I did notice was that installed and ActiveSync was questioned, and ran in the sandbox, I chose for it not to run in a sandbox and have it trusted. That’s something new. I then had the firewall prompt me about the incoming and outgoing connection(s) to and from my phone from ActiveSync. That is nothing new, so I clicked to trust the connection, and make it fully accessible, because that’s what I had to do in CIS 3, however, even when I chose those options, I was no longer able to sync my phone. Even if it was in training mode, the only way I can sync now is to disable to firewall, and I don’t want to go unprotected. I also removed the Firewall policy and re-loaded the “stock” policy, but nothing, it keeps denying the connection, unless I turn off the firewall. What should I do?

Can you post a screenshot of the Global Rules and the Firewall logs?

Here they are

[attachment deleted by admin]

I need some more information to get the picture complete.

I assume ActiveSynch synchronises data between your computer and your phone. Sorta like an iTouch or similar devices. Is that a correct assumption?

How does it communicate to the phone? What type of connection is being used? Bluetooth, USB, etc?

In general, yes it does sync like an iPod Touch, via USB.

One thing I forgot. When you choose to run a program not in the sandbox you need to restart the application. Did you do that?

Yes, I have, still nothing. Re-installing doesn’t seem to work either.

I see two IP addresses in the logs. I need to know the IP address of your computer when it is connected to the phone.

Go to Start → Run → type cmd in the run box and push enter → a DOS like black box will open → enter ipconfig /all and push enter (notice the space before /all) → now look up the IP address that belongs to the adapter that is related to Active Synch.

Was anybody able to synchronize with Activesync with Comodo Internet Security 4?

I’m having the same problem…just installed Comodo CIS Free 4.0.135239.742

No matter what i do Port 990 is blocked.

The Two IP Addresses used by ActiveSync are:


May be you need to open port 990?

Read the following little tutorial on how to open a port. Substitute the used port number with 990?

To open the port TCP 1723 for example

First step is to determine the MAC or Physical address of you network connector. Go to Start → Run → cmd → enter → a black box will show up and enter the following → ipconfig /all (notice the space before /all) → enter → now look up the Physical address and write it down.

Notice that Physical address = MAC address

Firewall → Advanced → Network Security policy → Global Rules → Add → fill in the following:
Action: Allow
Protocol: TCP
Direction: In
Description: Incoming Port

Source address: Any
Destination Address: Choose MAC address and fill in the found MAC/Physical address
Source Port: Any
Destination Port: 1723

Then push Apply → Now make sure that the new rule is somewhere above the basic block rule(s) as the bottom (the block rules have red icons); you can drag and drop the rules → Ok.

I have followed these recommendations. However, I regret to say that I cannot connect my Windows Mobile PDA to ActiveSync.

Any ideas, please.

im using windows mobile 6.5 and can connect to active sync.
but comodo sandbox is disabled though… you need to allow the ip of your mobile ( comodo will pop up and ask you when you connect your phone to the computer) and add rapimgr.exe to trusted application

Thanks for your suggestion. Regrettably, like all the other forgoing suggestions it didn’t work for me. But I’ve managed to ■■■■■ the problem, I run with my firewall set at Custom Policy Mode. I relaxed the level to Safe Mode. Thereafter, CIS did everything else for me. It automatically configured the network security policy with the appropriate application rules to allow rapimgr and wcesmgr access my PDA.

There was no need to open port 990 or any of the other ActiveSync ports.