Firewall interface locks up when adding files by browsing disk ( 32bit

User interface of Personal Firewall Pro version 32bit locks up if you try to add files by browsing the disk in any “My *** files” section of Defense plus. (EG using add/browse files in “My safe files”. You can add files by selecting processes with no problem.

The corresponding function on the firewall side, as opposed to the Defense plus side works fine. I have tried:

  • reinstalling several times
  • checking Faq and forum
  • disbling anativirus and anti-spyware real time protection (AntiVir, Adaware basic and Spybot)

I have found that if, in Defence +, the Commodo program group itself is allowed to run any executable, this problem disappears.

It would be better just to allow it to run a specific executable. I think this may mean that the default firewall settings for Commodo itself are wrong? Maybe it relates to windows explorer plug-ins (I use two applications that plug in to explorer - Idrive, a backup program, and Sony Ericsson phone/computer integration software).

I understand that 2 others have reported this problem and solved it by a clean windows install (thereby removing explorer plug-ins?) but I guess it may need a less troublesome solution!

This is a great free firewall.

Mike (convert from ZA Pro)

  • Your Internet connection type: ADSL max via router
  • Operating system and Service Pack Level: XP Pro SP2
  • How you are logging in to the OS: Admin
  • Other real-time security applications installed: Avira, Spybot
  • Security related applications which have been removed/disabled before installing CFP: Zonealarm, uninstalled
  • Security related applications which have been removed/disabled before installing CFP: None permanently, Aviria, Spybot disbled to try to resolve problem
  • Please inform us if you have created any custom rules: Yes, but problem occurs before custom rules created.

I manually add files to D+ all the time by browsing and it never locks up. What other security software are you using?

As above, Avira and Spybot. Disabling them makes no difference. Using Commodo D+ settings to allow Comodo itself to run any executable resolves issue, but is rather permissive.

So there is something strange regarding commodo’s own permissions going on here.


Oh should have siad that 2 others have reported similar problems and resolved them by clean install of OS, but of course this is more than most people want to do.

Best wishes


Re-opened per Request.

Thanks for unlocking.

One thought as to the source of this - My best guess after further investigation is that the bug may relate to explorer.exe add-ins commonly used for example to project mobile phone storage (eg Sony Ericcson) into the OS filesystem, or by on-line back-up programs eg Idrive.

Any one who hasn’t posted have any similar experiences? Are explorer add-ons implicated?