Firewall even blocks trusted applications!?

Hello world,

I have Comodo Firewall 5.3.176757.1236 and the problem that inbound connections are blocked, even if I defined the application as “trusted”.

Firewall Security Level → Custom Policy
Defense+ Security Level = Disabled
Sandbox Security Level = Disabled

In my case I want to use the FileZilla Server and I opened the port in my router.
Then I started the server, but I didn’t got a popup for it.
So I added the server process as trusted application.

Nothing works, nothing happens.

  • But if I set the “Firewall Security Level” to DISABLED, everything works as expected.

How can this problem be solved?

Where did you add it as a trusted application?

You should do this from Firewall → Network Security Policy → Application Rules.

I did this from the Firewall tab → Define a New Trusted Application and chose the running process.


Check if you have a global rule blocking all incoming connection (FW > Network Security Policy > Global Rules).

If yes go to FW > Stealth Ports Wizard and choose between the 3 rules the one corresponding to your private network config. The FW will automatically adapt the global rules.

Is this
“Block UP In From IP Any To IP Any Where Protocol Is Any” ?


Yes. You have a global rule blocking all incoming connections which usualy is the most convenient for users who don’t need to receive inbound connections.

But you want to receive inbounds connection

Then, please go to the Stealth Ports Wizard and choose either the 1st or 2d rule. If you need more information on the meaning of these rules, click on “What do these sttings do” in the Stealth Ports Wizard.


Thanks, I did that but I does not work.
I remember that I already used the Stealth Ports Wizard before, because I always have problems with my HP JetDirect network printer. This problem is also not solved yet.

The following link is for P2P, but the principle is the same than for your server.

For your network printer, please read this post

Many thanks, Filezilla works now with this method, though I did not get any alert. :wink:

Restore the old way by using the Stealth Ports Wizard (Firewall → Common Tasks) and choosing “Alert me to incoming connections - stealth my ports on a per-case basis” → Finish (see first image)

I’ll check the printer soon.