Firewall displays random process name and filepath instead of real one

Randomly, the firewall issues a window about the connection to the IP address and port that one of the running processes is using, which is already allowed access to this address and port. However, the name of the process is completely arbitrary, it can be “Windows operating system” or svchost, and even a recently uninstalled application that is physically removed from the disk and its processes are guaranteed to be completed.

Can you reproduce the problem & if so how reliably?:
No, It’s random.
If you can, exact steps to reproduce. If not, exactly what you did & what happened:

One or two sentences explaining what actually happened:
Firewall displays random process name and filepath instead of real one.
One or two sentences explaining what you expected to happen:

If a software compatibility problem have you tried the advice to make programs work with CIS?:
Any software except CIS/OS involved? If so - name, & exact version:
Any other information, eg your guess at the cause, how you tried to fix it etc:
I installed Comodo Firewal on another clean PC with newer Windows version and get same result.

Exact CIS version & configuration:
Comodo Firewall
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
Firewall only, other features disabled.
Have you made any other changes to the default config? (egs here.):
Logging: Write Windows Event Log enabled, Write to local base disabled.
Firewall Settings: Set alert frequence level: Very High, Alert timeout: 20sec
Application rules: All default rules removed after install.
Have you updated (without uninstall) from CIS 5, 6 or 7?:
if so, have you tried a a a clean reinstall - if not please do?:
Have you imported a config from a previous version of CIS:
if so, have you tried a standard config - if not please do:
No, standard config is not a option, too low security.
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 10 Pro 21H1 x64, build: 19043.1586
UAC disbaled.
Local account.
No VM.
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=No b=No

Hi ssechi,

Thank you for reporting, we will check and update you.


I added screenshot, may be it helps

nvidia container "connecting" to youtube (actually I opened youtube in the browser), cmc.comodo (comodo firewall checking updates or something) and router (svchost.exe do it sometimes).

Hi ssechi,

Thank you for providing the information, could you please check your inbox for pm and follow the guidelines ?
Kindly let us know your feedback.