Firewall Crashes & Burns

After installing Comodo, I’ve received a dozen “Comodo has encountered an error and must close” errors, and had to hard boot once because the program would not close. Trying to run the Updater causes the same problem. A very buggy product. PC Magazine jumped the gun on this one.


Have you tried downloading a new copy and trying again? (it could be corrupted download)
Have you made sure all the previous firewalls are cleaned up properly?
CPF is a fairly mature and stable product. Of course it has one or two bugs here and there but what you are describing is a major issue and we haven’ t encountered that one before.


Sound to me like you need to first make sure (as said) all other firewalls are gone\off as in XP case, and also , if you have a router with a firewall, may cause an issue or through your ISP. Also, do a malware\spyware and virus scan, most often it is from something lurking on your pc that causes this when trying to install a firewall or antivirus. You may need to clean up your drive or are having other issues as well, hard to say. What OS are you running?


I don’t have any other firewalls running. I uninstalled Zonealarm before installing Comodo. I uninstalled Comodo, downloaded a new copy and receive the same errors. Just opening this forum to read and reply, I got the same error message twice. Comodo just shuts down. I’m running XP SP2 with all the latest updates. I’ll run a registry cleaner and malware scan, no viruses on my pc.

I still think this is a buggy product and I’ll go back to ZA if the problems continue. Thanks for your help.

Well every software is buggy ( I am yet to see a bug free software :slight_smile: ), but lets concentrate on solving your issue.

Does Zone Alarm uninstall cleanly? There were few occasions where some firewalls don’t uninstall cleanly. Can you please check thru and clean zonealarm properly. Unless the previous firewall uninstalled fully, CPF will have problems.


That would be a good idea, also you may have other programs conflicting, do you run Limewire or some P2P, bit torrent, etc…? These will cause many issues when trying to install good security apps. Believe me, I have use ZA for years and I am no stranger to pc issues and Comodo is one of the better running progs out there.
My son just put Comodo on his PC last night and his system is far behind and he had no issues and was very happy with it.


I like a lot CPF, but when i install it my system try don’t charge a lot of icons, for exemple NOD32, spy sweeper and Tune Up mem optimizer don’t appears. I must to uninstall CPF and do a system restore.
When this issue or bug will be solved i’ll reinstall CPF.
I’m >:( because i like a lot this firewall and i can’t use it.

So what you are saying is: when you install CPF the sys tray icons for nod32,spysweeper, tuneup disappear?

can you pls provide us with full info on your system, apps you are running and drivers u might have pls.

My system is clean and I did another clean install, but get the same error. After the error, Comodo just closes. This is what Windows is reporting as an error:

AppName: clptray.exe AppVer: ModName: rchook.dll
ModVer: Offset: 00001b00

I can provide the dump file if that would help.

Here is the error when I try the Updater option:

AppName: cpf.exe AppVer: ModName: faultrep.dll
ModVer: 5.1.2600.2180 Offset: 0001206c

I can provide a file with my system info if that would be helpful

and yet another error. Comodo crashed and closes every few minutes so I’m afraid I need to go back to ZAlarm if I want a working firewall.

AppName: cpf.exe AppVer: ModName: unknown
ModVer: Offset: 6f737265

Yes pls.

I had to cut down the size of the system file to be able to post it, so hopefully this will be of some benefit.

[attachment deleted by admin]

Yes, it is
My PC is:
Intel Pentium IV CPU 2.40Ghz socket 478
Intel Brookdale i845PE
Motherboard Legend QDI-Platinix 8
ATI Radeon 9550 with the latest drivers of Catalyst 6.6
Bios:Award (12-06-02)

Edit. I formated my PC last weekend and i tested another one CPF and my problem is solved.
But now i’ve got an other problem.
I have a LAN with my brother, but when i have installed CPF i haven’t acces to it. A pop up says tahn i have got permissionb, and my bro can’t configurate in te LAN his PC.
We have a router and we have diferent conections.

First of all, you have to run the Network setup wizard again on your computer. I suggest closing Comodo for this. Run it and create a disk on your pc, then use the disk on his and restart both computers. (I assume you know how already but if you don’t , post back)

Open Comodo, go to security icon , click on it, on the right pane window click on Zone, enter name of brother, then enter private ip address.< If you don’t know his, on his pc go to Start , Run, type cmd , ok. Then in the box type, ipconfig. The addy will look similar to 192.167.x. xxx or something of that sort. It will be the first listed. > Once you enter the ip click ok. Restart the computer. If still won’t work then do the same steps but under the same window in Comodo, go to Add Trusted Zone, click on his name and finish the wizard. You may have to restart the computers. I don’t know what your brother is running for a firewall , if Comodo, you need to do the same.


Can you please try the BETA version. If it crashes, it will generate a bug report of its own. you can send that to us so that we can see what is happening…,1047.0.html


Well, i did it.
I solved all my problems .
Thanks a lot.
Now i have configured Comodo ;D

If you have a product without bugs you must to pay a lot oof money( and a lot of them have bugs too). This product is free. WE report bugs for future versions. It’s easy.

I’ve got a new problem.
CLI.exe(ATI catalyst) and processes of CPF consume a lot of memory RAM.
CPF and ATI catalyst are incompatible >:(

Is a very strong problem

I unistalled Catalyst :wink:

I expect in a future CPF and Catalyst will be compatible.
I like catalyst, but i prefer security. Please you would be solve this problem.

Sorry my bad english
I expect you can understand me.

Why 2 cli.exe’s? This should only appear once.

Have you tried downloading the latest catalyst drivers, removing existing and reinstalling?

Also, what version of CPF are you running?

Hope this helps,
Ewen :slight_smile: