Firewall can't trust application

The version is COMODO Firewall

It almost works perfect, but can’t remember the setting of one application:

I got the alert many, many times, but COMODO never remember the setting. I had add it in the trust application list, but still not work. (I am sure this application is in the trust list)

All other new applications works fine, and can been remembered by COMODO.
This application is the only one that COMODO does not want to remember…

What should I do to fix it? Thanks.

[attachment deleted by admin]

I can confirm the problem.
After the last update the application does not allow to remember settings anymore.

Several users have reported the same bug (although different applications for different people) To my knowledge there is no workaround at the moment other than to downgrade to the previous version.

Same problem here. It is really annoying.

i uninstall Comodo firewall because of this stupid problem…zz

Hello? Anyone here? Will you fix this bug?

It is fixed in an update of 8.2. However it got revoked. We’ll have to wait until they fixed what needs to be fixed.

Could please tell me how to do this?
What is the “group” mean? In comodo or in Windows?


Thanks for your help.
But this method looks not work in my case.

Havet you tried updating to the latest version


After upgrade to the new version, this bug finally been fixed


There is that.