Firewall Bug on Vista 64 - VMPlayer now MUST run as Administrator

Within the last month, users of VMWare’s VMPlayer running under Vista 64 with Comodo Pro Firewall installed began getting the error: “Incorrect version of driver “vmx86.sys”” when starting VMPlayer.exe. The common thread is that ALL of those getting this error message also just got an update to Comodo’s Firewall. We eventually came up with a work-around, which is to start VMPlayer “As Administrator”. See this VMWare Forum thread for more info:

Since most of us would rather not run this application as an administrator, I’m posting a request to have Comodo look at this bug and revert back to the previous ability to not require administrative privileges to run VMPlayer.

My Machine: Thinkpad T500, Vista 64 Ultimate SP1, Comodo Pro 3.8.65951.477, Avira Anti-Virus, SuperAntiSpyware 4.26.1000.


Update 5/25/2009:

Last night I installed VMWare Workstation 6.5 (latest build) and ran into the same problem. It MUST be run as Administrator to work successfully. Hopefully now that a ticket has been submitted, we can all get a fix so that any potential security risk can be avoided.

Have the same problem here. Vista x64, CIS 3.8.65951.477

Can you check if the “VMware Authorization Service” is set to “Automatic” and that the Log on is set to “Local system account”.

If these settings are all correct, please submit a ticket at:

This issue is very likely to impact on all users of CIS.

NOTE: I’m not aware that the ticket system has been restricted to paying customers (I didn’t realize Comodo was charging anything for any version?). If you have any problems submitting a ticket, post back and we’ll find a solution.

Yes, VMware Authorization Service is set to “Automatic” and the Log On As is set to “Local system account”, but the checkbox “Allow Service to Interact with the Desktop” is not checked.

When I tried to create a ticket in the past, only owners of Paid products could submit a ticket. Maybe that’s changed or they had some issue that day I tried…

Again, here’s a link to the thread in VMware:

This issue does seem to affect all CIS users on Vista 64 using VMPlayer (I don’t know about VM Workstation, but i’m going to install it later this week and test).

I have submitted a test support ticket, linking to this thread.

You don’t need to be a paying customer to submit a support ticket…

VM Workstation ran for me without having to run as Admin (note I was using an Admin account, though). Vista Ultimate x64.

Hi, I just want to say that I have the same problem.

Comodo Firewall 3.9.95478.509
VMWare Player 2.5.2 build-156735

Vista Home Premium SP1 x64
Avira Antivir 9


I have Windows 7 x64 and Comodo 4…

Having the same problem. Cannot run a Virtual machine in VmWare Workstation without having to run it as Administrator.

You might want to try this fix here, as another user has suggested the guard32/64 bug may affect account permissions

Best wishes


This is also affecting me on windows 7 64 bit. I run VMWare as limited user and I now it has stopped working. I get a message saying the VMWare authorization service is not running, but it is. Nothing is logged in defence+. Disabling the sandbox does not help.