Firewall blocks Internet Connection [at] School [RESOLVED]

first, i am german, so please excuse my poor explainment. Ask me if you need more details.
I am using Comodo quite a long time at home now. Great Suite!
This month i started to study, and at school we can use WLAN to connect to the Internet.
But i have Problems with connecting. well not connecting exactly, but with the internet (browsing). Pages load (<2 min) then comes an error (Connection to server resettet).

I am using Win7 now (but it didnot work with XP as well). At Home WLAN workes perfectly.
To connect to the WLAN (WPA2) you need typ your personal account+pw. Windows tells me, i am connected.

I also asked the people at the IT Service Center at School. they are in charge of all computer at the campus.
They told me i am connected to the server just as everyone else. I could also “ping” their servers.
I am not sure, but i think i could get 1 email with thunderbird.

They published a how to connect to the WLAN at their page. It is german but maybe the pictures help you. For translations, just ask me.

Uninstalling instantly solve the problem. Internet works. Even the Internet Page you get by uninstalling comodo loads.

What do i have to do, to get internet access?
As you might think, I am not at school right now, so i cant test anything.
thx for your help, i would like to keep using comodo.

Hi KUGA and welcome to the forums.

You could try to disable Blocking Fragmented packets.
Firewall > Advanced > Attack Detection Settings > Miscellaneous > Block Fragmented IP datagrams.

If that doesnt work can you pls do this.

Could you post a screen shot of when you connect to the network.

Did you by any chance stealth ports with CIS, or does this happen with defualt setting?


as i said i cant test till monday. what should the screenshot show? the comodo window of “new network found”?

did you mean change? i dont understand this sentence. And yes it happens with default settings, fresh installed windows with fresh installed comodo Suite

Yes i meant change… i hate that spelling mistake.
I needed to be a bit more specific… sorry my mistake.

Take a Screenshot of Firewall >View Firewall Events, when you connect to the network, so we can tell what is being blocked.

comodo seems to change something in my (windows) network stettings. Because disabled CIS and even closed doesnt help. only uninstalling

Sounds like a possible DNS issue to me. Did you opt to use Comodo’s secure DNS on install? It’s the only thing that I can think of, at the moment, where CIS changes the Network Settings (ie. the DNS servers) of the host system.

I first thought it could be MTU size but if it only works with CIS uninstalled I’m going for issue’s with the PEAP/MSCHAP this could be a bug. According to the documentation he should have set the IP settings both to Automatic (IP+DNS)… it is a good thing to check though.

I read the document and they are using PEAP(802.1x)/MSCHAP are you aware of working setup’s like this Kail ?

The DNS guess was mainly based on KUGA’s description of the problem.

Not really… sorry. But, wouldn’t an issue with authentication cause an out-right permanent failure rather than what has been described?

Could well be, i think we need a bit more feedback from the user…

I tried both, Comodo DNS and default. Does not work.
Well, i will print this posts here and try Omletguy´s suggestions tomorrow

Worked! Thx

Your welcome. :slight_smile: