Firewall blocking internet even when all rules are set to allow all connections

It’s been driving me mad for months. Before the bug only happened sometimes and I could refresh every page I tried to open to workaround it. Now I even have to disable Comodo Firewall to be able to get internet connection.

I removed all rules from Comodo Firewall and started from 0. I’m allowing every connection as it pops up, but I still need to disable Comodo Firewall to have normal connection.

At first I thought it’s a DNS lookup issue, but the bug occurs even when I refresh a page.

I believe it has something to do with Microsoft, as they are always the time wasters. Is it possible that because I tried rubbish*ty hyper-v the computer’s been messed up?

Any suggestion on how to fix this?

Do a clean re-install and don’t make any changes to the default configurations until it works correctly. Make sure the Windows firewall is disabled and don’t have other 3rd party security software installed.

Thanks for your reply. I have been trying multiple things lately.

Here are the two most relevant findings:

  • When a browser (or any app accessing the internet) suddenly becomes unable to load a page, relaunching (close/open) the browser makes it capable of accessing the internet again, at least for a while. So it is a routing problem. Some sort of route changes, apps are unaware of the change and thus unable to access the intenet unless they are relaunched or Comodo Firewall is disabled.
    Also, it’s quite intrigging that sometimes reloading the page works. (but many times does not, forcing me to disable comodo firewall)

  • Generally I have found there isn’t any problem with the wifi router (a phone tethering 4G connection). Other devices connected through the same phone/router were able to connect while the windows machine with comodo firewall was not. BUT! It has just happened that I was not able to access internet at all on the winwdows machine and restarting the tethering phone fixed the problem.

So it seems that the combination of Comodo Firewall with the tethering wifi phone is not working well.

Things I have ruled out:

Windows Firewall being enabled is not the cause of the problem. I reset Windows Firewall settings and then disabled it with no effect.

I have also completely uninstalled comodo firewall and installed a fresh Comodo 11 version. I have not played much with rules. There are apps I allow access and apps that I do not allow, such as Comodo Firewall itself. Svchost is the only app that I allow/block on per connection basis (so far not bloking any connection).

It is not a DNS problem neither. If I enable Comodo Firewall while a page is loading, the page does not finish loading.
It is a routing problem. Applications try to connect one way, but somehow it’s blocked. Or when you are in a page and navigate away to another tab of the same page.

Is there any setting in Comodo firewall that could be preventing the machine to update it’s internal ip / getting the route?


Have you tried disabling the dns client service. I have mine disabled mainly because it is not needed as I have a pfsense router that caches dns requests and secondly to make connected programs use dns rather than go through svchost.

Thanks. I didn’t know it was possible to disable dns on windows (and get connection). I have always wanted to completely block svchost!! Does windows work well with pfsense and svchost blocked? how do you do with other routers?

Coming back to the connection problems, dns resolution is for sure not the cause (the example of the page loading not able to finish if I enabled comodo firewall is definitive)

Latest finding is that the problem seems related to Network adapters. As you know, Comodo Firewall installs a network adapter “COMODO Internet Security Firewall Driver” (one of the the entries you can see when in the properties of a network connection). Lately, I have been trying to install Docker Toolbox on my machine. Docker Toolbox only works if you install Virtual Box with the legacy NDIS5 driver (the default installation uses the newer virtualbox NDIS6 driver).
I wasn’t able to get Comodo Firewall working together with VirtualBox and Docker Toolbox, so a couple of days ago I uninstalled VirtualBox and Docker Toolbox. Since then I am not having networking issues.
Still testing but I think this is it. Comodo Firewall does not play well with VirtualBox legacy drivers.

If this is the case… I would blame it on Microsoft, of course.
For some reason Docker Inc is very much into forcing Windows users to use hyper-v, a paid Microsoft product. Docker Toolbox was the way to use Docker on windows before Microsoft and Docker Inc “fell in love”, but it now seems abandoned, and Docker Inc very much discourages its usage.

I am very interested in the pfsense solution you mentioned because I have seen linux mini-pcs with pfsense preinstalled and you can also install a linux distro on them, so it should be possible to use a mini pc as both a router and second computer running Debian or Ubuntu for things like docker, kubernetes, etc… Things that are simply not worth rhe effort to try on windows.