Firewall blocking connection to TV for screen mirroring

Hi - I have a problem connecting my Win10 laptop to my Samsung Smart TV for screen mirroring.

A message is displayed on the TV that the laptop is attempting to connect but after a while, the laptop displays that it couldnt connect.

If I disable Comodo Firewall it connects without a problem.

Any ideas on what firewall settings changes I need to make?

Check the firewall logs for any blocked events and try to disable block fragmented IP traffic. If you don’t see any blocked events, then enable logging for the global block rule of block all incoming connections.

Hi - there is nothing in the Firewall logs.

I cannot see a rule for ‘block all incoming connections.’ - see attached

The last rule is in effect a block all incoming connections rule, but I see you have trusted your home network which means nothing should be blocked from other devices on your local LAN. For the firewall logs make sure you have set filter by date and time to no filtering. Also make sure the Windows firewall is disabled for each profile (Home,Work,Public). If you use an application that sets up the connection make sure you have an application rule with the allowed application firewall preset rule set for that application.

Well I’m afraid that nothing seems to be working

I’ve tried allowing all incoming/outgoing connections regardless of network.
Windows firewall was on but I’ve turned it off.
Nothing is being logged even after applying the filter.

A bit more information if it may help:
I am using Comodo Internet Security Premium 11 on Windows 10
The issue is happening via the Settings Menu > Devices > Add Bluetooth or Other Device > Wireless Display or Dock

I’ve just looked at this again and got it working by choosing ‘Alert Incoming Connections’ in Tasks > Firewall Tasks > Stealth Ports

I assume that this is not compromising my firewall?

I am not getting any popups on my home wifi so I assume the firewall on my Virgin v3 routers is protecting me there.