Firewall 8.2 file rating switch bug [M1553]

Can you reproduce the problem & if so how reliably?:
Yes, CFW 8.2 can reproduce the problem at each time when I try to switch file rating.
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1.) Go to unrecognized files via Widget.
2.) Right click on selected file(s).
3.) Change the rating from “unrecognized” to “trusted”.
4.) The selected file(s) replaced to the trusted.
5.) Go to “OK” button, the window closes. So far, everything is fine!
6.) Go to unrecognized files via Widget again.
7.) The replaced files appear again at the unrecognized files and Widget show zero unrecognized files.
One or two sentences explaining what actually happened:
Relocation of file(s) did not happen in reality.
One or two sentences explaining what you expected to happen:
I would have liked if I can relocate the unrecognized files to the trusted.
Any software except CIS/OS involved? If so - name, & exact version:
Any other information, eg your guess at the cause, how you tried to fix it etc:
The Diagnostics functionality doesn’t report any error.
Uninstall, clean reinstall.


Exact CIS version & configuration:
Comodo Firewall, Firewall Security.
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
Auto-sandbox enabled
HIPS disabled
Firewall Safe Mode
Virus Scope enabled
Have you made any other changes to the default config? (egs here.):
Yes or no: both.
Have you updated (without uninstall) from CIS 5 or CIS6?:
if so, have you tried a clean reinstall - if not please do?:
I tried.
Have you imported a config from a previous version of CIS:
if so, have you tried a standard config - if not please do:
I tried.
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows Vista SP2 32 bit
UAC disabled

[attachment deleted by admin]

Does this bug still reproduce with the lastest version found here:

If it does i can forward it to the devs.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time, availability, and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Thanks again

Please check with version <8.2.4703>.
Thank you.

Should be fixed with CIS moving to resolved, if you feel this is not fixed please PM a moderator. Thanks