Firewall x64 Crashes on Startup

I have been using Comodo Firewall Only with Vista Home Premium x64 for awhile now but the newest version x64 crashes on reboot every time.

This is the error it gives me:
Faulting application cfp.exe, version, time stamp 0x49a4531a, faulting module RICHED20.dll, version, time stamp 0x4791adc3, exception code 0xc0000005, fault offset 0x0000000000022550, process id 0x9c0, application start time 0x01c9a1542c034f64.

I can restart it manually and it seems to not crash but it’s not working correctly.
I can remove rules and it still allows the programs back with no permission pop ups and they don’t show up in the rules window. I tried to uninstall and reinstall and that didn’t fix it.

I am using Custom Policy Mode. My only other security apps are Antivir Free and SuperAntispyware Free (which is set not to run at start up.)
I have UAC turned off so I know that isn’t conflicting with it.

I have exactly the same problem here. Same error offset, same faulting module, same exception code reported by vista event viewer. On my pc however this error only occur occasionally though. And usually restarting pc will take care of that. But recently this problem started to develop it seems and occur more frequently. That’s why I came here to find solution. BTW I too am using Antivir Free edition like original poster. Is this just coincidence? Is comodo aware of this issue?

Found this Microsoft Knowledge Base article: . Does that solution work?

Thanks Eric…but unfortunately not. I have this riched20.dll in both system32 and syswow64 already and haven’t been using outlook for a long time now. It’s really strange because OP and I have different setup but getting exactly the same error. I mean my error log in event viewer is identical to the letter to what OP has posted. That’s why I think this error has got to be something to do with C.O.M.O.D.O itself. Any other suggestions?

Could you submit the bug as described here: ?

I have the same problem and it started when I installed a Wacom tablet, I don’t use Outlook.

Put Defense + to Clean PC Mode and reboot a couple of times. CIS will then learn the rules without giving a pop up.

When that doesn’t help try disabling the Tablet PC Input Service from starting with Windows. Does the problem go away? (Your Wacom Tablet will more than likely need this service to function.)

Opera browser used to have a problem with that service : .

Actually I can’t tell for sure because the problem doesn’t happen every time. It happened only once in 1 week so it’s hard to test. If it starts to happen more often I’ll tell you what happens when I do what you suggested.

Ok. Keep us posted if you have more information.