firewall 12 disabled by vanguard

Hello, created account just to report this issue.
Comodo firewall 12 gets disabled if Vanguard* is installed. (on system load Comodo firewall starts with error message, clicking on ‘FIX errors’ inside the application doesn’t resolve the issue)

*what is Vanguard?
major game dev company RIOT created an anti-cheat product named ‘Vanguard’ with long story short after learning on their mistakes of disabling ‘insecure’ drivers on system boot they apparently switched their approach to less intrusive

if you try installing RIOT new game Valorant, it also installs anti-cheat ‘Vanguard’, which on system boot checks for ‘insecure’ drivers(can’t confirm on that).
It seems this should not be happening since Comodo is the one issuing certificates and is major company in the field?
Could one of your testers actually try installing riot’s Valorant (vanguard) and checking on virtual machine or test machine, try to resolve what is going on?

win8 tested on newest comodo firewall 12 and 11

What is the Error Message & can you attach a Screen Print of it

(Just keep the posts to this thread . . . double posting just confuses everything)

‘AT RISK’ in the upper middle
the functionality of the program is all disabled
please read the full post to understand correctly of why it’s happening
also IP leaking to moderators? just why

I understand the explanation . . . would you attach the Screen Print please

of what? the gui of the program? nothing is changed except from green bar saying ‘SECURE’ to red bar with ‘AT RISK’
all settings stay the same, i did tests with version 11 and version 12 both with default settings and my own settings.
as soon as Valorant(Vanguard) gets installed after reboot, comodo gets into this state of being ‘AT RISK’ with the message that firewall might not be working correctly etc.
(there is no error number)
as soon as Vanguard(the anti-cheat) gets uninstalled and a reboot is performed, the firewall goes back to normal ‘SECURE’
edit the reason is clearly that the Vanguard anti-cheat disables comodo drivers on system boot, rendering comodo ‘AT RISK’

Yes - plus the other settings shown on the GUI

alright i see where this is going
sorry for wasting your time

Sorry for the intrusion…

I think @Ploget just would like to have some kind of, or more or less, “proof” or “evidence” of the red ‘AT RISK’ bar as this situation should never happen.
If possible please submit the screenshot so that they can fix the issue.

Just my two cents…

I’m not looking for proof. The other settings may have some relevance to the problem. It seems to be a serious issue with the Vanguard ant-cheat (kernel-mode driver) and appears to have got worse with one of the latest patches that was released

Hence my double quotation marks “proof” “evidence”.

alright, yes I’m not implicating it’s comodo issue per say, it’s somewhere in between.
and as I said before, tested it with default settings and my own, both had same result.

and so you are saying that there were people having both comodo and vanguard installed and did not have this issue(and this is semi recent)?
when the game(with Vanguard) was in pre-release stage(with public access), I did have it all working without a problem, it did not interfere back then.

I have vanguard uninstalled for now so that comodo actually works

There are a couple of posts and a Reddit thread concerning it with Comodo in particular: I’ll give it a try later on a Win10 machine and see what happens . . .

ok thank you!
make sure after installing valorant you launch it, let it install Vanguard, then as game says restart system so Vanguard actually loads
the 2 articles you provided have a point but are quite old and the devs did tweak vanguard to be less intrusive, but it does still block some drivers.

I had no issue with CIS as the vanguard tray loaded and the vanguard driver was running after restart when I finished installing valorant. But to note, there is nothing Comodo can do as kernel drivers can do whatever it wants including unloading and preventing other kernel mode drivers. This is on riot to fix as they are clearly preventing drivers from loading which I noticed with gmer driver not being loaded when vanguard was running.

and when was it? recently?
well you do have higher persuasive power if major program like Comodo would actually not be compatible with vangaurd it could be resolved very quickly

About an hour ago, maybe I needed to try launching game, but after the install phase I immediately rebooted and then checked to make sure both comodo and vanguard drivers were running using msinfo32.exe. They were all running and CIS UI displayed secure. Also I’m on Windows 10 2004 build 19041.329 with CIS using default proactive configuration.

interesting, Ill also wanna see Ploget response but if it is working for both of you should I try Uninstalling with Official Comodo Uninstaller v3.0.0.41 and reinstalling? maybe that would make a difference?

previously I used default uninstaller

(why is user IP displayed for moderators?)

I installed it and it ran ‘successfully’ on a Win10 2004 machine, but it certainly messed around with a couple of drivers . . . . fancyrd (RamDrive) didn’t load, which ■■■■■■■ up my environmental location for Temp folder, plus Samsung drivers were also blocked

Can’t test it on a Windows8 system, but what a horrible piece of software it is. Can’t be of much more help as it’s now uninstalled and gone