FireFox problems due to Firewall and / or BOClean...? [Resolved]


I want to start out by saying two things up front:

1.) I really like Comodo Firewall

2.) I’m not sure if this is related to Firewall, BOClean, or something else entirely…

But here’s the situation… I was running another firewall product up until about a week ago, when a friend of mine who I have a lot of respect for, computer- wise, sent me an E-mail about firewall comparisons. The one I was using was waaayyyyy down on the list, and Comodo was at the top. So I searched it out and found that the testing and results were legitimate (PCWorld, for instance, had some good info on the topic…). So, I deleted the old firewall and installed Comodo.

After spending some tiome with the new Comodo Firewall and liking what I saw, I decided to look into the BOClean, and installed it as well. No glitches so far, as of that date (about a week ago)…

Then, using Firefox, which is my default browser, I went to a site that I make purchases for my company from. It’s an industrial supply site, and I couldn’t log in. I mean, I couldn’t even see the home page. I got a redirect for some reason, and when I clicked it, I got the same redirect, regardless of how many times I tried. So I figured that McMaster’s site was having problems. This went on for about 3 days, until, on a whim, I tried Opera. Voilla! It worked. I tried Firefox again, and no- go. Hmmmmm…

Okay, only one site, I can work around that for a while. But I have a similar situation on Ebay now, and I spend a lot of time on Ebay. I can do everything on Ebay via Firefox, except sign in, which means, I can’t bid, or check messages, look at my summary, etc.

So, I try Opera… Voilla! Everything is accessible.

So I try Firefox… Nothing has changed… I can search Ebay, but can’t bid, message, see my summary, etc… all of which I CAN do on Opera.

Today, I tried the above using Netscape 8.1 and everything worked just fine… But, still having problems with Firefox.

I’ve been all through FirefFox now and have verified that McMaster and Ebay are NOT on any block list and that both are allowed to set cookies. I do have pop- ups blocked, but even went as far as to allow pop- ups on both McMaster and on Ebay, just to rule that possibility out.

The only thing that has changed, software- wise in the last 2 weeks is the addition of Comodo Firewall and BOClean. Is there something that I’m overlooking… or is the possibility that it’s related to the new security software just too far- fetched…?

Thanks for your input and help. This is a new inconvenience for me. Admittedly minor, but still, I’d like to resolve it. Firefox is my preferred browser and Thunderbird opens it whenever I click on a link in my E-mail. Since I get a lot of E-mail from Ebay, this has complicated things a bit, since I’m relegated to using 2 browsers at the same time for Ebay as a result.


Are you allowing javascript in FF?

Our web site makes use of JavaScript features. Click on your browser type for instructions on enabling JavaScript.

Try connecting to This is the IP address of the site. But they don’t appear to have a login page. I went through the Help files too and there’s no mention of a logon procedure anywhere.

Try connecting by running Firefox in Safe Mode (that’s Firefox Safe Mode, not Windows Safe Mode). There’s a link to it on your Start menu. If it works, then the problem is due to one of your Firefox plugins or add-ons. You can disable these one by one in normal mode in order to ascertain which one is the cause of the problem by going to Tools → Add-ons in the browser menu.

Another thing to check is your firewall logs. Go to Activity → Logs, change the option from “Today” to “Last 30 days”, then right click anywhere in the list and choose “Export HTML”. Give it a name and save the file somewhere. Then open it and look for items which are being blocked which are related to either McMaster or Ebay. To help you determine which IP addresses belong to which organization, download IPNetInfo from here. It’s a stand-alone program, so no installation required. Just copy/paste an IP address from the log into the utility, click OK and then double click the result.

Having said all this, I’ve also experienced a number of problems myself whereby I’m unable to post on this forum. Nothing happens when I click the “Post” button. I’ve been able to get around it by running System Restore and choosing a date and time prior to the problem occuring, but the cause remains a mystery still. It also happens in IE, so I don’t think it’s browser related somehow.


Last night, the power went off here for a short period. When I rebooted the 'puter, all was well. I can log onto Ebay and McMaster now… (!)

I had rebooted the computer a few times over the last week, as well as turning the firewall and BOCleaner off, in my various attempts. So I don’t see how yet another “reboot” would make a difference, but it seems to have done the trick this time.

The McMaster site has a login when you place the actual order. You wouldn’t see it unless you had entered some items and then attempted to enter an order. It’s a lot like Amazon in that regard.

Thanks a million for the replies here. I didn’t expect replies on a Sunday.

I came here today to say that, “all is well”… :BNC

Glad to hear you’re back up and running.
On that note I’ll mark this as resolved and lock it up.
As always, if the OP needs it reopened, IM a mod.