Firefox - New empty profile - Running in Comodo Container don't load web pages

Hello, as the title says, Comodo Container can not properly run Firefox with a new empty profile.

To reproduce the problem,

. A new Firefox profile is created,

. Create a shortcut to (“C: \ Program Files \ Mozilla Firefox \ firefox.exe” -p “Profile2” -no-remote) where “Profile2” is the name of the new profile,

. When you run the shortcut, Firefox opens, and you can see the following:

  1. The home page does not load
  2. If a new tab is opened and a web address is entered, it will not load either
  3. If you click on any of the pages that are offered in the new tab is not loaded.

If instead of running Firefox using an empty profile, it runs with a profile with history, cookies, bookmarks, etc., works perfectly within Comodo Container.

I just reinstalled Windows 7 SP1, it happened to me before reinstalling and it keeps happening to me now.
Before reinstalling, I had 360 Total Security as the antivirus, after reinstalling Avast.
Disabling 360 or Avast, the problem was not solved.
I use Microsoft EMET too, disabling EMET for firefox don’t help.

I use Comodo Firewall in Spanish, Automatic Containment, HIPS disabled, Firewall Safe Mode, Viruscope enabled.

The only changes to the default settings were
. In Advanced Firewall options, where i check all 5 options: ipv6 traffic filter, loop traffic filter, block fragmented IP traffic, etc.
. Define apps as trusted.
. User interface: unchecked “Show messages of Comodo Messages Center”, unchecked “Show Desktop widget”
. In Firewall unchecked animation effects

  • In “Detect shellcode injections” i excluded the Avast folder

When reinstalled don’t imported the old configuration.

UAC at default level, administrator account.

Hi Imdb456,

Please provide this files

  1. msinfo32 file by searching msinfo32 in Run command window and save as msninfo32.nfo
  2. Export your current CIS configuration using this help.
  3. Firefox version you use

Thanks in advance.

Kind Regards,

Hi, Firefox 53.0.3 32 bits EME Free, Spanish of Argentina (Directory Listing: /pub/firefox/releases/53.0.3/win32-EME-free/es-AR/)

Attached files requested.

I tried disabling all non-Microsoft services and all startup applications except Avast and Comodo, and it still does not work.

Can’t replicate. Most likely avast is causing issues with comodo containment. Try temporary uninstalling avast and also make a video to fully show the issue if possible.

Thanks for your interest, i recorded a video, sorry about the file size, but i could not compress the video itself, so i compressed it with 7zip.

Tomorrow i will uninstall Avast and post what happens.

[attachment deleted by admin]

Uninstalled Avast, disabled all non-Microsoft services, disabled all startup aplications, and the issue still happens.

Please check with thanks.

The new version was installed, when it was installed, the previous configuration was deactivated, and the default configuration was activated.

Using the default configuration of Comodo Firewall, the problem still happens

Most likely an incompatibility with avast or other software installed, make sure avast is fully removed and run any removal utilities from avast. I can’t replicate the issue. You can try adding firefox to detect shellcode injections exclusions to see if that helps.

Hi, when i posted in june 3, avast was uninstalled using the avast uninstaller, and the issue was still.

I tried adding firefox to detect shellcode injections exclusions and the issue was still.

What I could observe, contrary to what I thought earlier, is that Firefox works properly only if it has installed at least one addon with legacy technology, (for example quicknote - - See the link “Permissions”), regardless of whether it is an empty profile or not

(In the video, while quicknote is installed, Firefox works properly inside of Comodo Container, and with quicknote uninstalled, not longer works.)

But, if the only installed addon don’t has legacy technology, for example forecastfox fix version Forecastfox (fix version) – Get this Extension for 🦊 Firefox (en-US), Firefox still does not work properly.

Please check with Comodo Internet Security v10.0.1.6294 thank you.

Unfortunately I do not have more in my computer the configuration in which the problem happened. My old 80 GB IDE hard drive died, so the computer had to go to the technical service to install a SATA disk, and I took the opportunity to put 2 GB of additional RAM to the 2 it already had.

With a huge new 2 TB disk and 4 GB of RAM I installed Windows 10 x64, I use Comodo Firewall, EMET, and Windows Defender, and in this new configuration, the problem no longer happens.

By the way, the link to the new version of Comodo does not work.

Ok thanks I will move this to resolved and I fixed the link it had an extra l at the end of it. If you experience the issue again just reply here so that it can be checked again.