Firefox.exe is about to recieve a connection from the internet

OK so this was WAY out of the the blue and kinda worried in a way because ive never gotten a popup from comodo about firefox i blocked the request just because i was unsure and thats the typical thing to do here is the info on the matter

protocol : TCP
source IP :-
Source port :- 2028
destination IP :-
destination port :- 58210

ok il admit i am by all means no network expert but i am gradually learning so can anyone give me some insight into what was firefox was trying to receive and should i be even more worried if i have never gotten a popup from comodo about firefox trying to receive connects

any help would be appreciated


I have been having connection difficulties of various types since updating to Firefox 15.0.1 a few days ago.

Firefox crashes or stalls for several minutes. Certain sites, typically sites using SSL/https, generate the message page you describe. They warn that the certificate can’t be verified. Offer you the option of proceding ahead but warning against it.

I tried several things to clarify the issue. I pursued many dead ends and wasted a lot of time.

I finally took a careful look at the certificate store. You can do this directly from Firefox as follows:
Tools > Options > Advanced Tab > Encryption > View Certificates
This will open Certificate Manager. Click on the Servers tab. Scroll down to “The USERTRUST Network.” (When I tried to go to The USERTRUST Network on the internet, I was redirected to Comodo, so I’m assuming they are part of the same entity). Click on any of the items in this category. All of the items in this category are every day organizations we all depend on. But take a look - for example at the item . Click on the details tab. On this tab, click on Then notice the description field. It reads: Token:Bogus Google.

The certificates in this category are all issued by USERTRUST. But all of these certificates are labeled as "Bogus . . . "

These certificates are not just contained in Firefox. Open Windows Certificate Console. Move to the category “Untrusted Certificates.” These same certificates are listed as “Untrusted” or “Fraudulent.”
I have tried several procedures to get rid of the problem. I deleted what I assumed to be wrongly installed fraudulent designations on these certificates. I ultimately completely uninstalled Firefox, deleting all user settings, addons and any remaining items in the program and user data folders. I then reinstalled Firefox. The problem remains there unchanged.

So I finally began to consider that Comodo really has designated these certificates as fraudulent. Indeed, it looks like Comodo and Firefox are using what appears to be an innovative way of handling certificates. It allows the software to check up on just one certificate (instead of having to download an entire list of revoked certificates). But something has gone wrong. And . . . there doesn’t seem to be any way to turn it off!

The best way to describe Comodo’s role in the problem is to again look at the details pane of one of the certificates. Notice the “Authority Information Access” item. This is the address where your software is supposed to be able to check up on just the one certificate at a time. The URL is It turns out that Comodo itself blacklisted is own ocsp folder a few months ago. OK. I say very good. Sounds like a responsible company.

But a responsible company would also be taking steps to notify people who are being tortured by the fallout from this problem. Disappointingly, upon at last finding my way to Comodo’s site, I search for references to Firefox, comodoca, etc. There is nothing to be found.

Where’s the help. And why are fraudulent certificates being reinstalled in my Windows Certificate Store when I reinstall Firefox?

This problem has forced me to invest many hours tracking down the source. And, though its not often that one feels sorry for ones cable internet service provider, their technician concluded it must be their fault. He installed a new and upgraded router, new wiring. And they didn’t charge me because they figured it their equipment causing the problem.

Comodo needs to offer some help with this.