firefox addons disabled after installation of Comodo Internet Security

I’m not sure this is the right place to post or if this has been posted elsewhere on the forum.

I installed Comodo Internet Security Premium a couple of days ago and today I found out all my firefox addons were disabled. I’m not sure what happened but when I click on Tools on firefox and Addons. I can see the addons are still there enabled. It appears that I lost access to them. I tried adding Firefox as a trusted application in Comodo firewall but it didn’t work. Can anyone please help?


Hey and Welcome!

you need to add the things you added in firewall also in D+ if I am not wrong. Put the complete Firefox mapp in D+? if you don’t know how to do that tell me I will explain the procedure


Under what conditions is this a problem. I would naively expect Firefox add-ons to be allowed if I install CIS saying I have a clean computer, or to be prompted when I load firefox. How will it really work?

Just tried adding Firefox in D+ by clicking Trusted File - Add, but I got the message: Firefox is already a trusted file. Please tell me if I’ve done wrong. So I still have no access to the addons although they are physically there.

Thanks for your advice Valentinchen

That’s what I thought. Apparently Comodo is a bit different from ZoneAlarm Firewall I used before. I uninstalled ZA firewall and AVG antivirus (a resource hog) in favour of the Comodo all in one solution.


Maybe I shouldn’t have said addons are disabled. They are not. It’s just that they are no longer accessible because the All in One Sidebar Toolbar is missing from Firefox under View - Toolbars. This happened after the installation of Comodo in my desktop PC. I have no such problem with my laptop as I’m still using ZoneAlarm firewall and AVG antivirus.


OK, resolved the problem at last. It’s not CIS blocking the addons, it’s three files in Firefox profile folder corrupted: extension.cache, extension.ini, extension.rdf. Once I deleted the three files and restarted Firefox, the All-in-One Sidebar toolbar and other addons are restored. I suspected CIS as the problem occurred just after installing CIS.

Again, thanks for your help.