Final Snafu

Ok… hopefully someone will have a fix for this. I apologise in advance if this has been addressed/solved elsewhere in the forum. I did a search for the issue… nothing came up.

At the left of the application window, I have a red shield with a ‘X’ on it. It says below, “COMODO Application Agent is not running!” I click Run Diagnostics… it tells me ‘redirfs.ko’ does not exist, please run /opt/COMODO/, I get this…

[i]Build the RedirFS kernel modules for real-time protection…

Then linux kernel source or linux kernel headers for your current kernel version 3.6.3-1-desktop can not be found.
Please install the kernel source or kernel headers for 3.6.3-1-desktop, then run this script again.
make -C /lib/modules/uname -r/build M=/tmp/driver/redirfs modules
make: *** /lib/modules/3.6.3-1-desktop/build: No such file or directory. Stop.
make: *** [all] Error 2
make -C /lib/modules/uname -r/build M=/tmp/driver/redirfs modules_install
make: *** /lib/modules/3.6.3-1-desktop/build: No such file or directory. Stop.
make: *** [install] Error 2
FATAL: Module redirfs not found.

RedirFS kernel modules installation failed.

redirecting to systemctl restart
Stopping cmdagent: done
The cmdagent stopped successfully!
The cmdagent is already running!
redirecting to systemctl restart
Stopping cmgdaemon: done
The cmgdaemon stopped successfully!
The cmgdaemon is already running!

COMODO Antivirus is successfully configured, you can start it from Menu or Desktop.[/i]

However, the issue still exists. I’m running version 1.0.239818.1 - can anyone help? Thanks.

Solved this particular issue.

I have exactly the same problem. How did you solve it?

Not being anywhere near knowledged about Linux, I probably just did a ‘part way fix’. I found a download for the kernel source for 3.6.3-1, installed that, reran the shell commands, that fixed that particular issue. However, didn’t fix all. I wish someone else would reply on this, to clarify that we are doing this correctly.

This may help for Ubuntu - in terminal

sudo apt-get install build-essential kernel-package libncurses-dev
sudo /opt/COMODO/

Run CAVL Diagnostics

Scientific Linux - in terminal

yum install kernel-devel kernel-headers gcc make

Run CAVL Diagnostics

Appearently, OpenSUSE doesn’t recognize these terminal commands… thought I’d give it a shot though. Thanks.