FileZilla shell extensions appear to be blocked. Anyone else have this problem?

FileZilla’s shell extension for Drag&Drop downloading is not working on any of a half dozen PCs on which I’ve installed Comodo Firewall. FileZilla is set as a trusted application in D+'s settings. It does not seem to matter if D+ is enabled or not. I’ve tried to re-register the shell handler with no luck.

My guess is D+ is locking this handler out, regardless OR D+ is preventing proper installation of the shell handler. I tried to explicitly add the shell handler dll file to D+ and was told it is already in the list (FileZilla is in the list.)

Does anyone have a solution for this situation? I see it on XP Pro SP3 desktops as well as tablets.


Do you have any events in Defense+?
CIS > Defense+ > Defense+ Events
Also, Is FileZilla in the sandbox?
(CIS > Defense+ > View Active Processes > Right click the list > Sandboxed only)



There are a lot D+ of events but FileZilla is not one of them. Sandbox is disabled. I typically run with the firewall and D+ in safe mode, sandbox off. Avira free is the virus scanner (I’ll switch to Comodo when AV Comparatives shows similar results for CAV.) The only other malware blocking are NoScript for Firefox and URL black lists.

I’ve asked about this on the FileZilla forums and saw a response that D+ had interferred with FileZilla’s shell handler. I’ve never had any problems until the past month or so. That leads me to wonder if recent updates to CIS might have introduced a bug wrt FileZilla.

I also searched this forum for “FileZilla” and saw a number of posts, primarily about FileZilla Server. There is one post which requested FileZilla be added to the CIS company whitelist. It is not on the list yet, at least, it is not on the list on our computers.

If I disable the firewall, D+ and sandbox does that ensure the are completely off? I’m seeing similar problems installing Flash player in IE. My question goes to reducing the number of potential variables.

What happens when you add the complete FileZilla folder to Trusted Files.

The only way I know to add a folder is to click on “Trusted Files” in the Defense+ tab. When I do that, it takes a loooong time to see the list, as if everthing in the rules appears tos being checked again. I originally set the entire Program Files directory as trusted because I was sure they were safe. That results in 2 full scans which take an incredibly long time. It’s also too cumbersome to deal with D+ popups for things which I know are safe but don’t run frequently.

I can confirm the issue is with Defense+. I completely removed CIS and FileZilla’s shell handler for downloading works.

I am also thinking registry cleaners might be causing Defense+ problems. If there is a program in the whitelist which is later removed, some registry cleaners detect the path is no longer valid and offer to remove the registry key. Defense+ doesn’t seem to handle that well. The result are “empty” items in the Defense+ rules. It could use some form of quick integrity check.