False update prompt

I am running firewall component only (version 3.9.76924.507). I am not running Comodo AV.

Yet, I keep getting prompts in my tray that pop-up a window stating:

Updates are available. Would you like to start updating now?

Comodo gives no information in the pop-up window as to WHAT the update is, what version number, what component, etc. For all I know, it may be reminding me that there are AV updates even though I don’t have the AV installed.

Is there any way to cancel this annoying reminder?

That is to update the program not the av. Av has no update prompt they are automatic. Please update the the new .509 version, it is the most stable and newest one.

.509 version? According to the release notes on the download page, .507 is the latest version.

Release Notes
Check here for the latest Comodo Firewall + AntiVirus release notes.
Version 3.9.76924.507 : 13th May, 2009


It’s not, please update it.


The updates will put you to version .509
If you were starting fresh right now and downloaded the .507 installer.
During the installation process it would auto update to .509.
even though the official full installer is still at .507

Hope that clears it up for you.


Thanks BF - But I don’t use the auto updater. I like to have the full install package downloaded, available anytime and stored in my preferred hard disk location. The auto updater won’t allow me to do this.

How can I disable the auto updater?

Languy999: I hope the download link found in the link you provided is actually .509 since I just downloaded it again. Only about 6k difference in size between .507 & .509. Glad I have unlimited DSL.

It kind of sucks to now have to jump through all the Comodo hoops again (uninstall, reboot, reinstall, reconfigure) to install a new version 4 days after I installed the last one.

Yes I am the same about having the installer for what is actually installed on board.

Just wanted to give overview for folks downloading from the “official” download page ATM.

The link that languy99 provided is the full .509


PS. To disable program auto updates.
Miscellaneous > Settings > Update tab Uncheck the box “Automatically check for the program updates”
Select OK