Failed to update? [SOLVED]

I have just downloaded the “free” COMODO antivirus for Linux. I installed the software but can’t for the life of me update the software? I keep getting the following message:

Failed to update the virus signatures database.
Please check if the cmdagent service is still running

Would really appreciate any help and advice.

Problem solved

[SOLVED]?!?? Any hints what you did to solve this?

I’ve been battling this for hours trying to get initial database update. I restart cmdagent and cmgdaemon, sometimes even reboot, run diagnostics. Despite all that, I start the update and it gets to 90% and says “Finalizing…”, then BAM! The GUI shows a big red X and “COMODO Application Agent is not running!” and the update fails with the same error as you:

Failed to update the virus signature database.
Please check if the cmdagent service is still running.


For anybody else trying to solve this, I finally tracked it down to out-of-memory issues. On my machine, COMODO uses 450MB just idling. During the last phase of the database update, COMODO’s memory usage spikes and OOM Killer steps in and kills COMODO’s agent before the update completes.

Fortunately, I’m running this on a VM so all I had to do was allocate more memory and problem solved. Thanks for the bloatware, COMODO.

Hi BennTech,
High memory use maybe from a corrupt install or some other memory management issue.
I have an old test system, although it is Win XP (Not Linux) with 384 MB of RAM and CIS runs very light during general use.
Admittedly it does struggle during a DB update.

Just thanks would probably have done - after all it is free, and nobody makes you install it.

I can confirm though that CAVL used typically about 350MB on my machine (much more during updates).

I’ve now got rid of the mail gateway service and got this down to about 200MB.

LOL…yeah, but there are so few antivirus apps for Linux, and one of the few available can’t even update itself unless your machine has tons of RAM. Plus, it requires X so everyone using console-only has to forward X11 and connect remotely from an X11 system just to do basic configuration. PITA. And despite all the bloat, it doesn’t even have the basic functionality of scheduling antivirus updates or updating manually via the console. All in all, very frustrating experience.

But you are correct, it is free and nobody made me install it. (Still doesn’t change the fact that it’s bloatware.)