Failed to enable the Comodo VPN Adapter window appears on start up

Have tried reinstalling, run system cleaner reinstalled the Internet Security program but nothing I do will allow Easy VPN to work

I notice the Ineternet security add a nnetwork does not ask to allow conenction for the VPV when it starts first time so guess problem lies there

Have had it working fine in the past with same setup Win 7

Anyone out there any ideas? Appreciate a tip or two

Many thanks

as I know, Windows 7 is not supported with EasyVPN.

EVPN works here on Win 7 RC (7100). When needed try to install in compatibility mode.

Eric I to had it working in Win 7 7100 perfectly B4 with CIS but not currently.

Did it ask you to open another network? When I instal EVPN CIS is silent on another network being created which I recall the first time I installed EVPN it opened another network and it worked correctly then

Could I have a setting in CIS that is preventing a new network connection?

Thank you

What exactly is not working? Try deleting the rules for EVPN in Firewall and D+ and try again.

When the problem persists show us a screenshot of the firewall logs; to be found under Firewall → Common Tasks → View Firewall alerts.


Easy VPN Error window shows on start as below

Failed to enable the COMODO VPN Adapter. The P2P Connect could not be established. Please run this application as Administrator

The program runs as Administrator under Windows XP SP 3

Tye message above appears, click OK and the program opens you can see targets etc messaging works between clients pings ok try remote and client screen opens on my screen for a few seconds then just disappears

Thank you, Brockie

a new version is available, I hope it should not contain the error you posted.

Well I found a solution!!

Uninstal the program

Disable the adapter and

Reinstal the program AND at the final window UNTICK run the program now choice

Let the instal finish

Start the program and it works

How did you disabled the adapter after the uninstalation of the program?

I have the same problem

go to controll panel - > network connections

right click on comodo connection and choose disable.

I also have this problem with Easy VPN. The program works well on my Windows 7 laptop, but I receive this error on startup of my Windows XP (sp3) desktop.

The solution provided here doesn’t work for me. While uninstalling the program, comodo removes the adapter (as it should) - so there is no way to uninstall, then disable that adapter.

Another solution could be to install twice. If you try it, please report back if it works.

The QA team are looking into this issue.


no it didn’t help.

I have the same here. XP too. Exact message is appended.

I note that appshareservice.exe crdphappshare.exe do not seem to be registered as services. At least they do not appear under: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services. (rather broad this!) is defined as an automatically created network zone, with full file and printer sharing privs (all all IP in and out). No relevant firewall error messages.

I’m available on MSN if you wish to communicate.


  1. CIS version, AV database version & configuration used: 5.0 Build 1135, N/A,
  2. Whether you imported a configuration, if so from what version: No, N/A
  3. Defense+ and Sandbox OR Firewall security level: D+ & FW = Safe, S/B=
    Enabled, Treat as = Partially limited
  4. OS version, service pack, no of bits, UAC setting, account type: XP, SP3,
    x32, N/A, Admin
  5. Other security and utility software running: Security SW = all Comodo,
    utility please see CIS config report
  6. Virtual machine used (Please do NOT use Virtual box): None
  7. Hardware: P4 3GHz, 3GB available RAM, 160 GB hard disk (plenty free)

[attachment deleted by admin]