Failed Device-driver Uninstall with "Forcedelete" Loop

Greetings all.
Great product that I’ve used for nearly two years on several machines (Windows XP, Vista, 7 32- and 64-bit).
Now, for the first time, I’ve encountered a disastrous problem:
Dell Inspiron 1525 laptop
Intel 2 x 2.0GHz, 8GB DDR2, 320GB 7200 HDD (20+GB free)
Windows 7 Ultimate 64bit, fully patched, updated and maintained
Norton IS 2012, Malwarebytes, Mamutu, Windows Firewall (regularly run Kaspersky, ESET, etc., scanners offline. No malware.)
Have 350+ third-party apps installed for reference, testing and troubleshooting customers’ computers.

Problem: Using Comodo Programs Manager (CPM) I uninstalled Windows Mobile 2003 Device Driver which required a reboot to complete and, now, I cannot boot the system. The Windows logon screen appears, a message displays, saying, " Force delete jobs completing…". The system freezes there with a black screen, mouse cursor responds but no other activity. Even the LED showing HDD activity ceases.

Attempted solutions:
– Safe Mode(s), Last Known Good Config, etc., Startup Repair, (System Restore has been disabled.)
– BCD rebuild (successful)
– SFC will not complete from Windows RE Command Prompt
– Using Windows RE Command prompt, ran regedit-> File-> Load Hive and navigated to “Comodo Program Manager” installation directory and moved it to another folder on C: drive hoping that would break the call to the “Force delete jobs completing…”. No Luck.

I have looked into all the “fixes” suggested here, including the seemingly non-existent “forcedelete.txt”, Registry hacks and “cnat.exe” solutions.

No image is available :cry: and reinstalling all those apps, updates, tweaks, etc., etc., is not an option.
Suggestions would be most appreciated.


Bumping myself.

Moderator, Alexandru Andrei, provided additional information that may help others reading this post, although it did not help solve my problem… yet!

Note: In the older CPM versions the file [b]cpmnat.exe[/b] was named cnat.exe, [b]cpm_forcedelete.txt[/b] was named forcedelete.txt and the reference from the registry was named cnat also.
I could locate only cpmnat.exe. If anyone knows if there are other possible locations for the mentioned files/entries, please let me know.

I have access to the backups (One .xml file and one .cbu file) created during the failed uninstall. So,:
– What tool can be used to analyze Comodo’s proprietary format .cbu logs? What data-type is .cbu?
– Is there a way to use that backup at boot-time to restore the system?
– Does anyone have an aspirin? I have a massive headache. :-\


Does the force delete message still appears after deleting the cpmnat.exe file?
Another solution would be to remove the CPM drivers. Delete ‘cumon.sys’ and ‘evdd.sys’ from %SYSTEMROOT%\System32\Drivers location.

The “Force delete job…” message has stopped but other activity continues that I suspect is Comodo-related and the system still will not boot successfully.
If still no luck try to replace the registry hives with the backup ones, if they exists. They should be in %SYSTEMROOT%\System32\config\RegBack the files that have no extension are the ones that we are interested. Copy them in %SYSTEMROOT%\System32\config. Start with the ‘software’ hive and see if it has any effect.

In my particular case, this might be a possible solution for this specific “Comodo Situation” but it is definitely a sure recipe for creating many other issues if-and-when the system booted; for example, MS Office, antivirus programs and several drivers would no longer function properly, if at all. I will save that radical Registry manipulation for very, very last… if at all!
About the cbu file. It’s the comodo backup format but only CPM program can interpret the file succesfully with the help of the xml file.

I have yet to find a third-party application that will parse Comodo’s .cbu logs but there must be some. In the meanwhile, I will install Comodo Backup on another machine and see if I can use it’s cbu.exe to read CPM’s logs. Perhaps then, I will be able to manually copy/replace from a working system onto the problem system any files that the incomplete uninstall removed.

Bumping my own post again to report…

S U C C E S S !

My system is now fully functional again with NO reinstallations, updates or broken applications. In a few hours I will post a detailed report of exactly what I did to remedy the problem and, perhaps more importantly, what I did NOT do. I hope it helps someone else.

In the meanwhile, DO NOT follow any advice that entails editing or modifying the Registry in any way!

And, (I hope this sentence is not moderated away.) DO NOT LISTEN TO THE ADVICE OF “GeekBuddy”, two of whose techs (Aaron and his superior, Malcolm) :stuck_out_tongue: told me to use a registry cleaner, which itself is bad enough… but even if I were stupid enough to follow that “expert advice”, how could I…

Finally, it was Moderator Alexandru Andrei who provided a key piece to the puzzle.

Back soon…

We are waiting…


My problem was a very simple one to solve once accurate information was provided by the moderator, Alexandru Andrei.

However, please be aware: Mine was a more-or-less “planned crash” in that I expected Comodo to fail as it did. I had experienced something similar using a competitor’s product and, trying to fix that problem, thought that using Comodo Programs Manager (CPM) in a similar way would, either show me how a third-party uninstaller does its job correctly across a reboot, or allow me to track exactly what goes wrong when it does not. In either case, I would then have a better idea how to fix the “real” problem.

So, here goes the fix:

  1. Simply deleted the file that was being called at boot-time, in this case “cpmnat.exe”, which was being invoked before control was passed to the OS. Deleting it permitted Windows to get to the point where, although it still could not boot fully, repair was possible using its built-in tools: Diskpart, chkdsk, sfc and Startup Repair (in Windows 7 and 8 ). This works pretty much the same in XP and Vista, too.
    I may have actually caused or contributed to the problem by disabling the subject driver prior to running CPM’s Driver Uninstaller in an attempt to avoid in-use/access-denied type problems. Maybe(?) CPM would have handled things better without my “expert” proactivity.
  2. I then booted from my Windows 7 DVD. (My BIOS is set to boot first from the Optical Drive. If not done so already, you need to set yours similarly: Reboot and then, depending on your computer’s manufacturer, immediately press F2 or ESC or F10 or F11 or Whatever-gets-you-to-the-Setup-Screen. Get to a page where you can set the Boot Device Order where you’ll make the CD/DVD Drive first.)
    Now that we’ve changed the boot order, restarted the machine with the Windows DVD in the tray, we’ll press any key when the choice is offered to boot from the CD/DVD. Windows will do just that.

Here we choose Repair Your Computer .

We’ll then choose the Windows installation we want to mount and work with.

After a few more seconds, we’ll be presented with several Recovery Options and will choose the last, Command Prompt.

Next, we’ll determine the mount point(s) for the volume(s) on the drive using the diskpart utility and the list volume sub-command. Here, C:\ is the boot volume (labeled “System Reserved”) and D:\ is the system volume (where the OS and User data are stored on most newer OEM installations. Yours may be different, so double-check!)

We will start with CHKDSK to repair and/or verify the file system and to deal with any bad sectors. You may safely ignore “Failed to transfer logged messages…” .

Upon completion of the CHKDSK we will run System File Checker (SFC), sfc /scannow .
Based on the output of diskpart above, in this system, the correct command to run sfc is:

You may (probably will) see errors that were detected and repaired. If no unrepaired errors remain, proceed to reboot and,to be thorough, choose Startup Repair in place of Command Prompt, above. If there are detected errors which COULD NOT be repaired, then we are in for considerably more work. However, there is a good chance that the system will become bootable and any unrepaired files may be dealt with later.

Finally, a personal note:
Comodo is a great company with many great products, several of which, they generously provide free of charge. Their SSL Certificates, Secure Email and Firewall products are tops and I’ve confidently used them for years. However, as good as it is in tracking most software installations, Comodo Programs Manager is not capable of reliably removing/uninstalling software/drivers that require an intervening reboot. I do not know of any third-party uninstaller that is. Therefore, I am going to listen to that ‘little voice’ that told me not to try it this time. I’ll never try it again… unless and until a publisher specifically indicates that its software will continue monitoring during-and-after reboot.

I’ve actually had fun cleaning up my mess. I hope this helps someone else.

Thanks again, Alexandru for providing the key.


Post Script: Do not, repeat: DO NOT , fiddle with the Registry at all.


I have read this and tried all the tricks mentioned and still I get the force delete job at boot time

I did the following

burnt comodo rescue on CD and booted from this
went into mounted volume for my local drive
under windows\boot\driver the files mentioned here existed namely cmnat and cnat executables but I could not delete these so I renamed the top folder to tmp

then went into systemroot\rivers and renamed the sys files to tmp as well

then deleted and emptied user profiles, temp folders

I could not find forcedelete txt file anywhere may be it does not get created anymore

removed the Comodo rescue CD and inserted Vista rescue CD, no luck the boot process went into local HDD

yes BIOS set to boot from DVD for the first three options!

then shutdown and powered on again the PC

comodo perform force delete job<< appeared again promptly and the machine went into the infinite boot loop

so frustrating now, can someone come up with suggestion that actually works

CTM is not available though mentioned in this and many other forums and links provided but they end up on Comodo freebies page

any ideas? is CTM replaced by Geekbuddy or not? Is it paid tool?

desperate for help

Hi there beechwoodroad. It’s been a while since I originally posted but I believe I have all my notes and will try to help. If you haven’t already, please read the entire post and not just the portion you quoted in yours. What you quoted DID NOT WORK for me, either.

Also, as I did, please use a Windows Vista Installation Disk and not “rescue disks”. If you need one, you can find the right version here:
Make sure to select the EXACT Version/ServicePack you currently have installed.

Make sure you have full Administrator access to all files/folders referenced and again try what worked for me.

Please post and let us know your results.

Good luck. :wink:

I have downloaded the CD from DELL community and burnt into DVD and booted from this but nothing happens after ‘Starting Windows’ the screen just goes blank! I was expecting a repair option dialog to appear but nothing happened

I read the whole thread not just the one I quoted, in fact I did not want to quote anything but was fumbling with the buttons and navigation to post a message so I pressed quote so I Can get a window to type in my message

SO what was it that you did that worked?

Any suggestions as to what might be happening?

I managed to boot into the DVD and did the reair option then the repair went on for a while and the resuts were a failure - system repair cannot reair automatically

I went to command prompt and renamed all c*nat.exe files in the comodo folder and system32 then renamed the catroot and catroot2 folders back to original [problems begun with windows update errors 80070002 and 80004002] and also emptied softwaredistribution\download and datastore folders then rebooted the machine and went into repair then a message came to say system repair cannot detect any problems so I went into command prompt and did chkdsk and it ran for a while and finally service file trustedinstaller was recovered with some CBS logs files from index $I30 [part of the windows update nightmares the trustedinstaller service could not start as the file could not be found, how it got lost not sure for now], tried to run sfc with /offdir options butit asked for a boot so O booted up again and ran sfc but still it said a pendng repair exist and has to reboot first and I guess this is the comodo program manager thingie so I am rebooting for umptiethtime now to see if the comodo gremlin is gone

by the way I I could not boot from DVD as per DELL community thread so I made USB stick [16gb they come cheap these days I bought 2 for 15 pounds]

fingers crossed now the boot is almost done…

Hey there beechwoodroad,

If your problem originally was caused by CPM, I believe my procedure will be (would have been) successful. I think you made things worse than they were, with all the deletions, renamings, etc., all of which make “permanent” changes to t System Files, including the Registry. Hopefully, what you are now doing will work or, if it does not, we can get back to the original non-working state and fix whatever specific issues were introduced by CPM.

Please post the last CBS.log file if anything goes wrong.