Failed Connection

I have Windows 10 and I’m using free xfinitywifi hotspots to connect to the internet. I do a lot of traveling and I’m always connecting to unsecured hotspots. So usually I’m always getting new IP Address. I wanted to use a VPN to help solve my unsecured wifi problem. Problem is that it’s not connecting. I get the following message:

Wed Jun 21 14:51:28 2017 OpenVPN 2.1.1 i686-pc-mingw32 [SSL] [LZO2] [PKCS11] built on Dec 11 2009
Wed Jun 21 14:51:29 2017 WARNING: Make sure you understand the semantics of --tls-remote before using it (see the man page).
Wed Jun 21 14:51:29 2017 NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables
Wed Jun 21 14:51:29 2017 LZO compression initialized
Wed Jun 21 14:51:29 2017 Attempting to establish TCP connection with
Wed Jun 21 14:51:29 2017 TCP connection established with
Wed Jun 21 14:51:29 2017 TCPv4_CLIENT link local: [undef]
Wed Jun 21 14:51:29 2017 TCPv4_CLIENT link remote:
Wed Jun 21 14:51:29 2017 WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this
Wed Jun 21 14:51:49 2017 [ComodoVPNS-2] Peer Connection Initiated with
Wed Jun 21 14:51:52 2017 AUTH: Received AUTH_FAILED control message
Wed Jun 21 14:51:52 2017 SIGTERM[soft,auth-failure] received, process exiting

I pretty tech savvy but networks and connections are not my strong suit. Any help would be appreciated.

This appear to be a problem with the TrustConnect servers that is affecting multiple users, as I have the same problem where I haven’t been able to login to the TrustConnect service since about 9:00 PM (CET) two days ago…

I have a support ticket regarding this, and in the last staff reply they said (partially quoted):
“Some of our COMODO Trust connect customers facing the same problem. We have forwarded this issue to our developers.”

Ok thx. I just bought it and if I’m wondering if I just ask for a refund at least until they fix it.

I’ve been using TrustConnect since 2015 without any major problems - until last wednesday about 9:00 PM (CET) where I tried to connect, but the connection failed with the AUTH: Received AUTH_FAILED control message error, and hasn’t been able to connect since that.
The last successful connection were about 6:30 PM (CET) the same day, so something has happened sometimes within that about 2,5 hour timeframe.

A few hours after I discovered the problem, and also after doing some tests and analysis to exclude possible problems with my local system or network causing this behavour (as I’ve been working with computers since the 1970s (!), I should have experience to rule out local problems), I sent a support ticket.

During my own analysis, I also discovered the following after trying new reconnections after each connection attempt failed:
The server leave multiple endpoints in the TCP/IP stack with the state LAST_ACK, as seen in the snapshot below, and are not closed until TCP/IP is closing these endpoints due to timeout (after some minutes), so possible this server could play a role in this problem?

It’s now almost three days since I sent that support ticket, and the TrustConnect service is still not working.
It seems that COMODO is not taking this seriously, as my experience with other companies is that problems on their servers and systems are checked and fixed within short time after notifying them of possible problems.

I want to thank you for posting on this thread. I got nothing from Comodo and you’re the only person had any possible fixes. I just bought a new notebook and this is the first time I’ve been able to mess around with testing things on the Windows 10. So I wasn’t sure if it was some setting in Windows 10. I then decided to use Psiphon 3 and it’s having no issues. I think I’m just going to pony up and get a premium VPN server. Shame this didn’t work, I like the AV and other software. I’ll probably ask for a refund for TrustConnect.

I have a similar situation, the connection is not established.
Stigbye, you are not scared of such entries in the log?

Wed Jun 21 14:51:28 2017 OpenVPN 2.1.1 i686-pc-mingw32 [SSL] [LZO2] [PKCS11] built on Dec 11 2009

Almost 8 years have passed since the release of Comodo TrustConnect. Over the years, in its prototype OpenVPN, which is developing very dynamically, many vulnerabilities have been found that can compromise the data transmitted inside the tunnel. OpenVPN constantly removes these vulnerabilities in its products, and the Comodo Group does not. Although their work is only in creating a library for displaying the client’s icon. What prevents them from promptly updating both the client and the server, which, among other things, are currently using weak encryption? I do not understand how a company dealing with network security can sell such an unsafe service. And now it’s impossible to use CTC at all and the company is silent and does not react to customer complaints in any way. I used to think that in the US this is impossible. I was wrong and now I’m very disappointed in Comodo.


As COMODO doesn’t seem to take this seriously and fix this problem with TrustConnect, I have now fixed it myself…


By installing and using another service that is almost identical in usage and GUI appearance as COMODO TrustConnect (and that also have 20 different access servers thougout 9 different countries), so now I have secure Internet access again … but NOT thanks to COMODO…

And as a comment to the reply from Fyord, it’s of course using the most recent OpenVPN version, as seen from the following excerpt from that applications log file:

Mon Jun 26 14:13:16 2017 OpenVPN 2.3.17 i686-w64-mingw32 [SSL (OpenSSL)] [LZO] [PKCS11] [IPv6] built on Jun 20 2017

As a joke in the country where I live: “the Rescue of drowning is the handiwork of drowning”.

eck. I just paid for this ■■■■ for a whole year too. I’m getting my money back. I guess its for the best, there are much better VPNs out there anyway.

What do you guys have to say about the antivirus software? I only got it because I read in Wikileaks that the NSA had the hardest time with hacking Comodo. It’s the only reason I got it.

I got a direct email asking how I “fixed” TrustConnect by installing one another and similar application.

I therefore made a single page with a description of what I did, which is found at the following address:

As I made that page in “just a couple of minutes”, I apologize for possible typos and minor language errors (English is not my native language)…

sorry but you didn’t “fix” anything, you simply paid for another vpn service…

back on topic… THIS IS TERRIBLE, comodo should fix this issue as soon as possible. I whitelisted the trustconnect ip on some remote servers i need to use for work and now i’m locked out because their vpn service is down and keeps showing an AUTH_FAILED message!

I hope this is solved VERY FAST because i need to use the service, i can’t believe this issue was reported on june 21 and customers are still unable to use the service after almost 2 weeks >:( :-TD

As you probably noticed, I wrote the word “fixed” in quotation marks, which implies that I of course didn’t fix TrustConnect itself.

BTW, I still get replies from Comodo to my support ticket regarding this issue, and this is the latest reply I’ve got:

Dear Customer, Thank you for contacting COMODO. We apologize for the inconvenience caused, We are completely aware of the issue and our team is working with high priority to get these issues fixed. Kindly give us a day time to come up with a permanent solution. Once the issue is fixed we will make sure that your subscription days lost will be extended. Thanks and Regards, David GeekBuddy Support Team

Hi, I been using Trust connect for the past year and have had no probs with it, I even share connection through Win 7 64 ICS routed through Ethernet to an old router I have pumping out the signal for my home devices, I disabled the routers own DHCP server so win 7 gives my devices there IP Addresses, Anyway the other day after a successful connection many times I have had the same error…

Mon Jan 29 12:10:55 2018 OpenVPN 2.1.1 i686-pc-mingw32 [SSL] [LZO2] [PKCS11] built on Dec 11 2009
Mon Jan 29 12:10:55 2018 WARNING: Make sure you understand the semantics of --tls-remote before using it (see the man page).
Mon Jan 29 12:10:55 2018 NOTE: OpenVPN 2.1 requires ‘–script-security 2’ or higher to call user-defined scripts or executables
Mon Jan 29 12:10:55 2018 LZO compression initialized
Mon Jan 29 12:10:55 2018 Attempting to establish TCP connection with
Mon Jan 29 12:10:55 2018 TCP connection established with
Mon Jan 29 12:10:55 2018 TCPv4_CLIENT link local: [undef]
Mon Jan 29 12:10:55 2018 TCPv4_CLIENT link remote:
Mon Jan 29 12:10:55 2018 Connection reset, restarting [0]
Mon Jan 29 12:10:55 2018 SIGTERM[soft,connection-reset] received, process exiting

looking at the probs you guys have been havin, I will be terminating my subscription with Comodo shortly, Anyway guys, Nice to meet you

Many thanks…

Mon Jan 29 12:10:55 2018 SIGTERM[soft,connection-reset] received, process exiting

Just for your information:
This error is NOT the same error as this topic/thread is about!

Occasionally, I also get the “SIGTERM[soft,connection-reset]” error with the other VPN service I installed to substitute Comodo TrustConnect, and this is usually a temporary problem, most commonly due to network connetivity problems.

In my case, I’ve most often encountered this error when there occasionaly is a poor WiFi-connection between my computer and the wireless router/access point I’m using.

Ah ok stigbye, Thanks for your feedback, I was actualy connecting via Win 7 Control Panel\Network & Internet\Internet Options\Connections and then creating a VPN to comodos server their but I am unable to do that now, Could you tell me if their are servers that allow that connection instead of downloading a TAP-Win32 Adapter V9 Pliease, Again thank you for your promt response & that you have more experience in thease areas more than I do, Otherwaise I was unable to connect again with Trust Connect & that before I may leave Comodo try any other vpn connections with them, Many thanks stigbye.

Robertlee-1, some days ago, provided you have registered a valid email address in your profile on this forum, I sent you a direct mail about your last reply.
If you somehow haven’t got that mail, mail me (I DO have a valid email address registered in my profile on this forum) and I’ll resend it.

Hi Stigbye, I was that fustrated that i asked for help on a different topic that day, Anyway, With all due respects firstly to Comodo, I have cancelled my CTC Account with them, Sorry guys & Secondly want to thank you Stigbye for your assistance in regards to my problem and again, Appologise for going off topic, Many Thanks