Extreme SlowDowns experienced when running PrivDog with CD

Hello, this bug report is related to this one, but as I do not get any errors reported by Comodo Dragon (CD) I believe it is a separate bug.

I have found what I believe is the easiest way to see this distinct slowdown. With PrivDog enabled (all other extensions disabled) I go to this page. Then right click on any of the articles and select “Open link in new tab”. The new tab will open and the page will begin loading. However, it will load very slowly.

If I disable PrivDog, and again open the same link in a new tab, the page opens quickly.

This slowdown is not minor. I timed it. It takes the page about 42 seconds to load enough content to be usable with PrivDog enabled. With PrivDog disabled it only takes about 2 seconds to load the same amount of content. Also, this behavior seems to replicate itself on at least most other sites (if not all) which have ads replaced by AdTrustMedia.

As it appears that this is not happening on all computers with PrivDog installed I assume it may be something particular to mine. Thus, please let me know what sort of diagnostic information would be of most help to you.

Thank you.

Okay, I decided to re-install CD to see if it would solve the problem. At least for now I am not experiencing these slowdowns. Thus, perhaps it was the last update which caused some sort of corruption.

I’ll let you know if the problem reemerges. However, for now I’ll add fixed to the title of this bug report.


Thanks for your feedback. We will check this case also

Thanks, although I can’t seem to replicate it.

Actually, I am starting to see marked slowdowns yet again. Also, and this may be related, it appears that ads are sometimes replaced on pages and sometimes left blank. Thus, is this possibly caused by PrivDog having difficulty contacting the AdTrustMedia servers?

What information can I provide to assist you in identifying, and fixing, this issue?


Yes, there is some difficulties on server side now, so we may help only patience. Situation must be fixed later today or early tomorrow.

Okay, so is it a current bug in this version of PrivDog that delays on the server side can affect the speed of user’s browsing?

I believe that this sort of dependency needs to be sorted out. Perhaps it’s necessary to put a certain amount of time which, if the servers cannot be reached, PrivDog falls back to just blocking all ads for that page. That should be a good way to balance, unless I’m misunderstanding the situation.

Sorry, but i don’t know all tech facts about it, but seems to me situation must be fixed tomorrow by server-team. So if problem will be not solved, we will investigate it further.

Okay, please let me know what time it is fixed on your side. I won’t comment on this until then.


Ok, i will report it asap.


I’ve noticed that the website that I experience the most slowdowns with is http://www.vitalbmx.com/. Sometimes it would load quickly with no issues but other times it would be stuck at “Waiting for node1.adtrustedads.adtrustmedia.com…” for about 15 seconds or longer.

Sorry, but seems our problem not solved completely, so devs will look more closely today.

Thank you for the update.

Let me update current status. This problem was resolved on 25 July, so for now you shouldn’t feel any speed problem.

Anyway, if you still feel any decreasing of speed or other problem - please report to us.

For now everything seems fine. I’ll report back if I encounter any additional slowdowns.


It appears this is happening again. It’s not quite as bad as before, but is still a long ~15s delay.

Sites with ads are loading very slowly with PrivDog enabled. One example is:

However, if I disable PrivDog the site loads fine.

I assume this is an issue with the PrivDog servers, but to make sure this does not happen again can you please add in some sort of backup plan, whereas if the servers are taking too long to respond PrivDog just blocks the trackers and loads the normal ads.

I think this sort of a solution would work for most users.


Chiron this is inform to you.
this website work fine for me when PD enabled.

It’s working fine for me now too. Perhaps they fixed it on their end.

Yes, seems problem fixed and you shouldn’t feel any problem in ads delivery speed, If you will see it appear again - please report here.