explorer.exe problem at startup.

System: Windows 7 Ultimate 32bit, latest updates
Ram: 2GB
CPU: QuadCore @ 2.66
CIS: 4
Other: Immunet Protect, MBAM realtime
Problem: when system starts, after welcome screen, there is a black background with nothing but a white mouse pointer.
Workaround: CTRL+ALT+DEL then terminating explorer.exe and then via new task start explorer.exe again. Everything loads.
Workaround2: Disabling Defense+

Profile: Internet Security, trusted files added to my safe files. Sandbox disabled.
System has no viruses, no slowdowns, no popups.

Can anyone assist?

What does Immunet do? Can you globally explain what type of application it is.

May be Defense + is blocking something. Can you check the D+ logs to see if there is anything being blocked during boot time? The logs can be found under Defense + → Common Tasks → View Defense + Events. Can you post a screenshot of them?

ImmunetProtect is a cloud antivirus seen here:
It is active as soon as you connect to the internet. It has no performance decrease and can be used alongside any antivirus as a backup. As long as you’re connected, it protects you.
D+ is blocking something, because when I put it in training mode or disabled, all is good.
Sandbox is disabled because it sandboxes known good programs I put myself in safe list.
Now I am gonna enable d+, restart and post a screenshot.

Ok, just restarted with d+ in clean pc mode and it worked! :-TU
I put tons and tons of my trusted programs in safe list, that must have worked…
Here’s d+

TaskKiller is a small tray icon program that can be used to terminate any process, and it’s really good, when a program stops responding… It is a safe to use if you know what to kill when it stops working.
Anyway, will test through in today, if it happens again, I will post here, if not under 24 hours, lock it down!
Thank you for your assistance and patience, sir!

No problems now…
I deselected Block unknown processes if the application is closed in D+, so I figure since CIS is not loaded yet, D+ blocks the explorer or some program from loading.
It works now, close this, and thank you. :-TU