Exclude checkbox doesn't work in some cases (v3.0.17.304 x32) [FIXED]

Previous reports can be found starting from this link.

AMD Athlon™ XP 2500+ x86, Windows XP SP2 x32
Actively-running security and utility applications: CFP, CMF

F+ custom policy mode, D+ train w/safe mode.

Advanced settings of F+ are default, except: alert frequency level set to “high”, option “This computer is an internet connection gateway…” is unchecked, options “Protect ARP cache” and “Block gratoitous ARP frames” are checked.

Advanced settings of D+ are default.

Example 1.
Predefined policy “Web Browser” has rule Allow Outgoing FTP-PASV Requests.
Exclude checkbox works as expected in this case.

Example 2.
P2P client eMule is configured to receive incoming TCP connections on port #27988.
two rules are created for eMule.exe:

block/tcp/in/any/any/any/NOT 27988

Result: incoming TCP connections on port 27988 are blocked, though they should be allowed because option “Exclude (i. e. NOT the choice below)” is checked.

3.0.18 behave in different way: with same rules incoming connection is not blocked anymore but firewall alert is shown that eMule.exe is trying to receive connection on port 27988 (custom policy mode). Though this connection should be allowed silently. Moreover, if one more rule is added at the end of the list for eMule.exe: block all unmatching, connection on port 27988 is blocked.

EDIT: Bug is fixed in 3.0.18.

I think that is the correct behavior, as the checkbox means the FW will not apply the rule to the connections to that port, it does not tell what to do to these connections. The user may want an action other than allow or use more complex rules.

I guess you are right. So bug is fixed.
Btw, if issues that you experienced with exclude checkbox in previous versions are fixed in 3.0.18, let us know please (your topic #1 and your topic #2).