Every update resets "Full Scan" and "Quick Scan" to default settings [V6][M569]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?: yes, every update
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
  1. Export config (or just remember scan settings) before update.
  2. Update.
  3. Compare with settings before update.

After the update the schedule frequency, heuristics and other settings are reverted to default.

This is valid only for “Full Scan” and “Quick Scan” profiles.

This issue exists since 6.0 and earlier (5.x).

  • If not obvious, what U expected to happen: CIS should upkeep our scan profiles
  • If a software compatibility problem have U tried the conflict FAQ?: no
  • Any software except CIS/OS involved? If so - name, & exact version: no
  • Any other information, eg your guess at the cause, how U tried to fix it etc: CIS overwrites first two scan profiles with default settings
  • Always attach - Diagnostics file, Watch Activity process list, dump if freeze/crash. (If complex - CIS logs & config, screenshots, video, zipped program - not m’ware) attached config from 2847 (before update) and 2860 (right after update) and diagnostics file, please PM for password

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration: 6.2.285401.2860, custom (attached)

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV: AV (stateful), FW (custom), BB (blocked)
  • Have U made any other changes to the default config? (egs here.): yes
  • Have U updated (without uninstall) from a CIS 5?: no
    [li]if so, have U tried a a clean reinstall - if not please do?: n/a
    [/li]- Have U imported a config from a previous version of CIS: yes, 2847
    [li]if so, have U tried a standard config - if not please do: no
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used: XP, SP3, 32b, DEP, admin, no VM
  • Other security/s’box software a) currently installed b) installed since OS: a=no b=no

[attachment deleted by admin]

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

This is annoying and should have been fixed by now.

Now that it’s reported hopefully it will be. :slight_smile:


there are other options that are reseted with the update.

User Interface:
Logging - Move it to (…)
Show welcome screen on startup
Show information messages when tasks are minimized/sent to background
Enable password protection

Virtual Kiosk password

GeekBuddy popup when malware is found

There’s probably more but it needs to install a previous version, change every option available, update and the check what was reseted.


Hi legnakrad,
The recent releases have resolved most or all the issues you have listed.
Please do tell if this is not the case for you.
Please check the topic in the link below.
CIS updater always displays message for the background mode
Thank you.


I’m not sure this is the same bug. But then i can only reproduce it in the next cis update…

i moved form v5.x to v6.x
I made a fresh install of cis v6.2.282872.2847 (av+fw+hips+sandbox)
Later get new update available info (v6.2.285401.2860). didn’t make update yet (past bad experiences :wink: )
Even later, i finally did the update. the config reset took place.

After your reply i did the steps mentioned in the link you provided but didn’t reset any config.



None of those things have happened to me on any one of my machines in any OS version. Only the scheduled scan settings were changed back. I do not use passwords for the Kiosk or any part of CIS however.

Can you please check and see if this is fixed with the newest version (6.3.294583.2937)? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

PM sent.

The scheduled scan settings still revert back to defaults in the latest update.

Thank you for checking.

I have updated the tracker.

2937 - confirmed, still resets default scan profiles.

Thanks for confirming this.

Can someone check and let me know if this is fixed with CIS version 6.3.301250.2972?


Seems fixed for me.

Thank you for checking this. In that case I will move this to Resolved.

If anyone is still experiencing this issue please respond to this topic.

Thank you.

I forgot to make sure of one thing. I have already moved this to Resolved, but can move it back if any of the below issues are not fixed as well.

If anyone is still seeing that the settings for the above-mentioned issues are not fixed please let me know.

Thank you.


No resets with the last update (6.3.294583.2937).
Well, actually something happened: after cis update » pc restart the widget showed up but just briefly and disappeared to oblivion (where it belongs) ;D

thank you